This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I have given him editor rights to make changes for one single particular post with the above details he gets access to click on the Courses (post type) and edit the single School he is authorised to. The problem is that when he clicks to the edit button the translator is not working.

Solution: I noticed that the client was using a plugin to edit the capatibilities of each user role. To assign the capatibilities to edit the translations, you should assign the "wpml manage translation management" capatibility.

I added this capatibility to the editor role and now the editor is able to edit the translation of the courses post type.

This topic contains 8 replies, has 2 voices.

Last updated by Diego Pereira 11 months, 3 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
October 26, 2018 at 3:01 pm #2853422

randhird

i have created a new user callled harshad.

[content removed]

I have given him editor rights to make changes for one single particular post with the above details he gets access to click on the Courses and edit the single School he is authorised to.

The problem is that when he clicks to the edit button the translator is not working ( English to marathi ).

after you click on the edit (pencil icon ) its going to to wrong post.

Can you please help us resolve this issue urgently.

[content removed]

Kind Regards,
Randhir Dange

October 29, 2018 at 12:01 pm #2857826

randhird

dear sir / madam

have not received any response regarding this issue . please do you help us .

really waiting for your response

randhir dange

October 29, 2018 at 3:32 pm #2858617

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @randhird, welcome to the WPML support Forum!

Sorry for the big delay. We are with a big load of tickets at this moment. This is not common in our forum.

I noticed that you are using the Advanced translation Editor to edit the website. However, the new user (Harshad) does not have a subscription for the Advanced Translation Editor.

Please go to WPML > Translation Management > Translation Roles and click at Manage translator subscriptions to grant access to this user.

Please let me know if it worked for you.

All the best,
Diego

October 29, 2018 at 6:11 pm #2859156

randhird

Hello Diego,

thank you for your response . i total;;y understand your work overload .

i tried your process you suggested (Please go to WPML > Translation Management > Translation Roles and click at Manage translator subscriptions to grant access to this user) >>>> not working>>>>>

also when i click on edit button it goes to Translations queue page.

also a suggestion about two weeks back advance translater was not working . when you got it working the user id (harshad) worked fine . suddenly it stopped. what can be the reason . sorry for pushing it but my client needs it online.

please if you could get it working as many users need to be added to edit.

thank you

regards

randhir dange

October 30, 2018 at 5:15 am #2860503

randhird

this problem is not resolved

October 30, 2018 at 1:55 pm #2862099

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I noticed that you are using a plugin to edit the capatibilities of each user role. To assign the capatibilities to edit the translations, you should assign the "wpml manage translation management" capatibility (see screenshot).

I added this capatibility to the editor role and now the editor is able to edit the translation of the courses.

After that, if you go to Courses > Courses and click on the pencil icon, you will be redirected to the translation queue screen. At this page, you can click on the "Translate" button to translate the page.

Another option is to edit the translation using the manual editor:
- Go to the edit screen of the page (original language).
- Change the language using the Language switcher at the top admin bar
- if it display a warning, click on "Edit Anyway"

If you need more help just let me know.

Kind regards,
Diego

October 30, 2018 at 5:49 pm #2863148

randhird

thank you for your help sir,

once i am taken tooTranslations queue page. i am taken to the wrong post . not to the post that is editable, the post page ids to be edited are different . please check the title of the post its different . this happens to all the users i have created
please can u help me on this .

regards

randhir

October 30, 2018 at 6:19 pm #2863242

randhird

hi Diego
thank you so much i guess the problem is solved. thank you again

regards

Randhir

October 30, 2018 at 7:44 pm #2863549

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there, I'm glad to hear that the issue is solved ?

Please contact us if you need our help in the future with WPML. We will be more than happy to help.

Cheers,
Diego