Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 3 voices.

Last updated by Bill Lafferty 9 months, 3 weeks ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
April 24, 2020 at 3:50 pm #5988181

Bill Lafferty

Hi Drazen,

From the hosting provider:

"We were hoping that the update to WordPress would fix the issue, but since it didn’t, we have attached the entire debug log for the site. We would recommend sharing this with Bill. It should help him figure out the solution."

I need to upload the debug.log file, could you send me a link?

Thanks.
Bill

April 27, 2020 at 8:16 am #6000267

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hello Bill,

I haven't received any update to my last reply, did they update libxml to the latest version and followed my instructions? Please let me now.

My reply: https://wpml.org/forums/topic/critical-error-when-uploading-completed-xliff-via-translations-page/#post-5983753

I have enabled private next reply, please share it as the last time using dropbox or similar filesharing service.

Thanks and regards,
Drazen

April 27, 2020 at 11:16 am #6001755

Bill Lafferty

Hi Drazen,

The client said that they updated to the latest version of WordPress as well as the WPML plugin. The debug.log file can be accessed at the link below. If we can't pinpoint the issue based on that, I'll have the client reach out to you directly for next steps.

hidden link

Kind regards,
Bill

April 27, 2020 at 11:32 am #6001833

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hello Bill,

thanks for the update, it seems there was a misunderstanding in our communication. Maybe I was not clear.

The issue is not in WordPress, they need to talk with their hosting provider and need to update PHP libraries on the server, in this case, libxml.

Currently, the server is probably using libxml 2.7.6. which doesn't have these functions.

LIBXML 2.7.8. or higher is required for WPML to work correctly.

Info: hidden link

Please share the next info with the client and hosting provider.


You can see it says: undefined constant LIBXML_HTML_NOIMPLIED and LIBXML_HTML_NODEFDTD, and that is because these functions don't exist. Currently, your server is probably using libxml 2.7.6. which doesn't have these functions.

Info:
-
hidden link
- https://stackoverflow.com/questions/40911718/domdocumentloadhtml-expects-parameter-2-to-be-long-string-given-when-trying

I advise contacting your hosting provider and ask them to update libxml to the latest version or at least to Libxml 2.7.8.

Ticket with the same issue: https://wpml.org/forums/topic/when-translating-pages-only-the-title-shows-up-to-translate-not-the-content/#post-5939313

Please let me know how it goes.

Regards,
Drazen

April 27, 2020 at 1:23 pm #6002709

Bill Lafferty

Hi Drazen,

Thank you for the additional information, I've passed it along. Can I put the client directly in touch with you if they have more questions? Please advise.

Thanks very much.
Bill

April 28, 2020 at 7:41 am #6008923

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Thanks, Bill!

Yes sure, if after updating libxml they still have issues, I can continue the conversation in this same ticket with the client directly.

Thanks and regards,
Drazen

May 7, 2020 at 1:57 pm #6080573

Bill Lafferty

Hi Drazen,

The customer would like to have a meeting with you. After updating everything, we are still getting a critical. Can you provide times you are available?

Kind regards,
Bill

May 7, 2020 at 2:12 pm #6080843

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hello Bill,

this ticket was closed, I haven't close it.

We do not provide that kind of support, all support is provided via the forum.

- https://wpml.org/purchase/support-policy/

I advise to open a new ticket and share a new debug log to see what new errors happen. Also, check with the client is it possible to share credentials so we can check the issue.

Be sure to check WPML’s Minimum Requirements are met:

- https://wpml.org/home/minimum-requirements/

- WordPress 4.7 or later
- PHP 5.6 or above with memory limit of at least 128MB while 256MB is recommended (see WP memory settings). Keep in mind that the required memory for your site depends on your content, theme and all plugins.
- MySQL 5.6 or above.
- WordPress REST API must be enabled for WPML to function properly.
- Multibyte String extension for using WPML String Translation
- SimpleXML extension for using XLIFF files in WPML Translation Management.
- The eval() PHP function must be enabled. More about this in the section about eval().
- The libxml PHP Module 2.7.8 or higher

(CONFIRM WITH CLIENT)

Please open a new ticket and one of our supporters will continue this conversation.

Let me know if there is anything else I can do for you.

Thanks,
Drazen

May 7, 2020 at 3:28 pm #6081999

Bill Lafferty

Hi Drazen,

The ticket must have closed automatically.

I'll open a new ticket with login creds to the customer's account so you can have a closer look.

Kind regards,
Bill