This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Radu 3 months ago.

Assigned support staff: Radu.

Author Posts
July 12, 2019 at 9:18 am #4196935

krzysztofB-10

Hello,

I have 2 problems.

1. How to enable your plugins I can not create new pages - a critical error appears

2. I have a default English translation, and he sees Polish - how to set it to be ang?

July 12, 2019 at 10:17 am #4197485

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Thank you for reaching out the WPML support!

Let's take care of each issue, one at a time. First, can you tell me what happens when trying to add a new page or if you see any error message, please? A few more details about this would help me understand what happens and look for a solution to get things back to normal.
Also, it would be great if you could give me access to the dashboard area so I can have a look at this too. The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

July 15, 2019 at 10:39 am #4209891

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Giving me access to FTP was really helpful. I was able to check the log file and see what's the error thrown by the plugin. It seems that there's a wrong value to the database. In this case, please follow these steps (after creating a full site backup) and tell me if you still have issues creating new pages:

  • Go to your database using phpMyAdmin(or something similar);
  • Go to wp_icl_translations database table;
  • Find entry with element_id:2755 and delete that row.

Let's take care of this first and then we'll have a look at the second question too.

Thanks,
Radu

July 19, 2019 at 1:23 pm #4246733

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I wasn't able to access the dashboard area of the new website link that you send to me (hidden link) so I tried again to create a page on the previous website (hidden link). I was able to create a translation for the About us page (hidden link) without running again into that error message. Can you tell me if you changed anything on your website in the meantime?
As a side note, a strange thing is that you have Polish and English languages but the language switcher from the top left corner of the page is showing English and French.

Thanks,
Radu

July 22, 2019 at 8:10 am #4254613

krzysztofB-10

Great, but please, like from point 2? How do you set the ang language by default?

July 22, 2019 at 10:52 am #4256327

krzysztofB-10

I already know everything is great! thank you!

July 22, 2019 at 12:34 pm #4257189

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Can you give me a few more details about the second question, please? Maybe you can attach a link to a page where you have that issue so I can check it out.

Thanks,
Radu

The topic ‘[Closed] Critical page addition error’ is closed to new replies.