This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Mihai Apetrei 2 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
August 6, 2019 at 1:36 pm #4347801

sharonA-6

I want to incorporate there css styles for my language switch, already spent hours and hours, and nothing works...

kindly help....

these are the css codes that I want to incorporate

font-family: roboto;
color: white;
font-size: 15px;
text-transform: uppercase;

if you allow me where I can change that element it would highly be appreciated.

thanks!

August 7, 2019 at 3:22 pm #4356479

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Can you please try one of the 2 code snippets below and see if that works?

.wpml-ls-native {
    font-family: roboto !important;
    color: white !important;
    font-size: 15px !important;
    text-transform: uppercase !important;
}
div.wpml-ls-legacy-list-horizontal .wpml-ls-native {
    font-family: roboto !important;
    color: white !important;
    font-size: 15px !important;
    text-transform: uppercase !important;
}

If none of them work, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

August 7, 2019 at 4:29 pm #4356857

sharonA-6

it works (the 2nd code) but not in the global effect...

How to put in global effect?

im using a thrive architect page builder.

what im doing to take it effect is to put the code on every single page of the whole website.

I just edited 4 pages. homepage and the blog page.

I tried putting it to, addtional css on wpml, theme, theme editor, and on thrive theme option... or did i miss something?

How to put in global effect? where to put it?

August 7, 2019 at 4:35 pm #4356883

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I am happy to hear that we are making progress.

I did not use the theme that you have installed on your site until now so I don't know if it has a global custom CSS page, but you could install a plugin like this (https://wordpress.org/plugins/simple-custom-css/) and add the code there.

Please let me know if that solved the issue.

If not, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

August 11, 2019 at 12:47 pm #4376979

sharonA-6

imma try this and I let you know...

thanks!

August 12, 2019 at 3:01 pm #4381767

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

That's great!

I am assigning the ticket back to you for the moment.

Please let me know how that went and if it accomplished what you were looking for.

I will be waiting for your answer.

Kind regards,
Mihai