This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 3 voices.

Last updated by Carlos Rojas 3 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 28, 2019 at 12:25 pm #3906825

Floris

I'm getting the following error on my WP dashboard:

====

Installer cannot contact our updates server to get information about the available products and check for new versions. If you are seeing this message for the first time, you can ignore it, as it may be a temporary communication problem. If the problem persists and your WordPress admin is slowing down, you can disable automated version checks. Add the following line to your wp-config.php file:

define("OTGS_DISABLE_AUTO_UPDATES", true);

===

I've read that this might be because of the blocking of cURL by my hosting provider. I've talked to my hosting provider and they can whitelist the IP addresses of the necessary WPML servers.

Can you give me the IP addresses of the WPML servers, so I can have my hosting provider whitelist them?

Thanks,
Floris

May 28, 2019 at 4:59 pm #3908977

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Here are the domains to whitelist. Please test the following and let me know your results:

hidden link 74.50.57.24
hidden link 54.230.11.118
hidden link 52.200.8.253
hidden link 54.230.11.56

Please let me know if you need any further assistance and I will be happy to help.

June 3, 2019 at 7:21 am #3939783

Floris

My hosting provider whitelisted the IP-addresses that you mentioned, but I'm still getting the following message:

===

Installer cannot contact our updates server to get information about the available products and check for new versions. If you are seeing this message for the first time, you can ignore it, as it may be a temporary communication problem. If the problem persists and your WordPress admin is slowing down, you can disable automated version checks. Add the following line to your wp-config.php file:

define("OTGS_DISABLE_AUTO_UPDATES", true);

===

Do you have any other ideas what this could be?

Thanks,
Floris

June 3, 2019 at 7:23 am #3939791

Floris

Additional question: if I add that line to my wp-config.php file, does it only concern the WPML update check process? Or the whole update process of WordPress itself?

June 3, 2019 at 12:57 pm #3942501

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please add define("OTGS_DISABLE_AUTO_UPDATES", true); to the wp-config file. This only concerns the WPML updates, not the general WordPress updates. Let me know if that resolves the issue.

July 1, 2019 at 1:57 pm #4119727

Floris

Hi there,

Thanks for helping out.

I'm still getting error messages. My hosting provider has whitelisted the domains that you mentioned. I've added

define("OTGS_DISABLE_AUTO_UPDATES", true);

to the wp-config file.

Now I get this error message: "WPML could not load configuration files, which your site needs." Detailed error message:
2019-06-29 14:31:098561 index wp_error wpml-config/config-index.json
code: http_request_failed
message: cURL error 7: Failed to connect to cdn.wpml.org port 80: Connection timed out

Do you have any tips on what to do next?
Thanks,
Floris

July 2, 2019 at 9:45 am #4125419

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Floris,
My name is Carlos and I will be taking this ticket because my colleague Lauren is on vacations.

I kindly ask you to visit this link where you will find a similar ticket and the answer from one of our colleagues: https://wpml.org/forums/topic/cant-register-plugin-or-download-assets/#post-1560610

Best regards,
Carlos