Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.31 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Currency does not change when switching between languages. It always use shekel as currency.

Solution:

Temporarily set the multi-currency setting for each language to 'Keep'. Save changes.

Then, changed it back to 'USD' for English and 'ILS' for 'Hebrew'.

This topic contains 15 replies, has 3 voices.

Last updated by Dennis 8 months, 3 weeks ago.

Assigned support staff: Dennis.

Author Posts
March 12, 2019 at 8:59 am #3319615

doronN

This is a two-part question.

1. (a bug) - under woocommerce multilingual > multi-currency > Currencies I have USD and ILS (which is the default site currency. When trying to set the Default currency for each language (En, He) it doesn't "stick" - it reverts to USD for both. I would like them to be USD for En and ILS for He.

2. (a question) - under "Automatic Exchange Rates" on currencylayer added the API key getting "Access Restricted - Your current Subscription Plan does not support Source Currency Switching. (January 22, 2019 1:31 pm)" - what does that mean?

Thanks

March 12, 2019 at 7:43 pm #3327823

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

1. I can see that WPML and its add-ons are not updated to their latest version on your site.
Could you please updated everything and see if the issue persists?

Also when you are writing "When trying to set the Default currency for each language (En, He) it doesn't "stick" - it reverts to USD for both.", I'm not sure exactly what you are doing.
Can you elaborate on the process that you are doing and attach some screenshots if needed?

2. I guess that you are using the Free subscription from Currencylayer so it means that they have restrictions to what can be the currency. Maybe because you are using ILS, you get this message. This issue is not caused by WPML. Please, a reference for this on another ticket in our forum.
https://wpml.org/forums/topic/exchange-rates-for-multi-currency-not-working/

Thanks,
Itamar.

March 13, 2019 at 8:18 am #3330561

doronN

Hey
Multi-currency > Currencies >Default currency. He->ILS. EN->USD (see screen shot).
when viewing a product in Hebrew - suppose to default to ILS. Instead - show USD first.

Coming back to Multi-currency > Currencies after a refresh or save Default currency is USD for both languages.

It's a development environment so if you need access I can provide

Updated to latest version. Issue 1 still persists

March 13, 2019 at 7:53 pm #3337989

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hey.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

March 14, 2019 at 9:40 pm #3348623

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for the access details.

I can see this issue on your site.
Could you please try the following?

I suspect that there is a collision with the theme or another plugin that might cause this problem. If possible get your site into a minimum environment. Minimum environment means switching to a default WordPress theme like Twentyseventeen and no plugins activated except WPML.
Is it possible for you to try it?
You will need first to check if the problem persists when just the theme is switched to Twentyseventeen (for example). If it persists then deactivate all plugins except the WPML and its add-ons and WooCommerce itself. Then please check if the problem persists. If it does not persist so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Thanks,
Itamar.

March 17, 2019 at 8:15 am #3362881

doronN

Hi
Disabled all plugins except those (see attached image) and switched theme - didn't resolve it.
What's the nex step?

March 18, 2019 at 5:12 pm #3371781

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for trying my suggestions.

If the minimum environment procedure did not point to the problematic plugin or theme, please do the following:
Please provide me with the WordPress debug.log
Please check this page for instructions.
https://wpml.org/documentation/support/debugging-wpml/
Look under the headline "Enabling the built-in debugging feature in WordPress".
To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);.

Change it to:

define('WP_DEBUG', true);
// Enable Debug logging to the /wp-content/debug.log file
define('WP_DEBUG_LOG', true);
// Disable display of errors and warnings which is recommened on a live site.
define('WP_DEBUG_DISPLAY', false);
@ini_set('display_errors',0);

After enabling the debug log please repeat the action that causes the issue (try to change the currency).

In this case, the errors will be saved to a debug.log log file inside the /wp-content/directory.
If you can paste your debug.log to pastebin.com and provide me that link, it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

Please, could you provide me the additional Info?

Thanks,
Itamar.

March 21, 2019 at 8:26 am #3396651

doronN

https://pastebin.com/Uca7rtir

Let me know if you need anything else

Doron

March 22, 2019 at 9:07 am #3438769

Dennis

Hi,

Itamar is on vacation so I am taking care of this ticket. Hope this is okay with you.

I would like to request your permission to install Duplicator plugin and download a copy of your site and continue debugging locally and escalate if necessary. Please let me know if I can proceed.

https://wpml.org/faq/provide-supporters-copy-site/

Kind regards,
Dennis

March 24, 2019 at 8:22 am #3447865

doronN

Hi
Sure - What exactly do you need?

March 25, 2019 at 3:51 am #3449571

Dennis

Hi,

I need your permission to install Duplicator plugin, build a package and download a copy so I can continue debugging locally. Please let me know if I can proceed.

Thank you.

Kind regards,
Dennis

March 25, 2019 at 7:38 am #3450121

doronN

Yes you may

March 25, 2019 at 9:24 am #3450967

Dennis

Hi,

Thank you for your reply.

I will try to build a Duplicator package, download a copy and deploy on my local machine. Then I will continue debugging your site locally and will give you feedback when I got some results.

Kind regards,
Dennis

March 26, 2019 at 3:22 am #3459023

Dennis

Hi,

I have temporarily set the multi-currency setting for each language to 'Keep'. Save changes.

Then, changed it back to 'USD' for English and 'ILS' for 'Hebrew'. It seems that it solves the issue.

Could you please check and confirm if the issue is now resolved at your end?

Thank you.

Kind regards,
Dennis

March 27, 2019 at 8:30 am #3468585

doronN

Yes. Seems to resolve it - strange...Hope this solution will last