This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by Bruno 1 year, 6 months ago.

Assigned support staff: Bruno.

Author Posts
November 13, 2018 at 4:41 pm #2903764

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Our compatibility team has found another workaround that helps to keep the "Currency" option enabled, if necessary.

- Open the wp-content/plugins/booster-plus-for-woocommerce/includes/class-wcj-currency.php
- On line 34, replace this line:

add_filter( 'woocommerce_currency_symbol',  array( $this, 'change_currency_symbol'),          PHP_INT_MAX, 2 );

- with this line

add_filter( 'woocommerce_currency_symbol',  array( $this, 'change_currency_symbol'),          10, 2 );

- Save and upload the changed file

After these steps, even activating the "Currency" option on the WooCommerce > Booster Settings should work correctly.

Thank you.

November 15, 2018 at 4:05 am #2908877

ryanW-5

HI~ it resolve my problem. thank you.

November 15, 2018 at 12:13 pm #2909939

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Glad to hear that it now works. Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

November 16, 2018 at 9:31 am #2912916

ryanW-5

Thank you very much.

November 16, 2018 at 11:55 am #2913469

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Sure. You're welcome! 🙂