This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by athloneH 10 months, 1 week ago.

Assigned support staff: Bruno.

Author Posts
July 17, 2019 at 11:52 am #4229691


I am trying to: automatically and / or manually update currencies using or and getting an error: "Cannot get exchange rates. Connection failed."

Link to a page where the issue can be seen: Dashboard > WooCommerce > WooCommerce Multilungual

I expected to see: The currencies should update once a day.

Instead, I got: an error: "Cannot get exchange rates. Connection failed." (See attached screenshot).

July 17, 2019 at 9:13 pm #4233551


Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Fixer uses the Euro as its base currency. Are you using the Euro as your base currency?

This is the message displayed below the "" option in WooCommerce Multilingual:

WARNING! Minor limitations include 1000 requests/month limit and EUR being the only available base currency for customers using a free account. If you need more than 1000 requests per month or want to use all 170 available base currencies, you’ll need to choose one of the paid plans starting at only $10 per month.

You can see more on the Fixer documentation page: hidden link. If your site is not using Euro as a base, this option may not work as expected with

Thank you.

July 18, 2019 at 4:18 am #4234929


Hi Bruno

Thank you for the reply, but I must say, your reply is all but useless.

My first question: did you read my ticket carefully? I indicated that I've tried BOTH and <-- the two options WPML provides for currency updates in WMPL, and BOTH do not work.

Second question: Did you look at the provided screenshot? In there you'd see that the base currency was GBP with USD and Euro's as other currencies.

Once again, how can I resolve this issue?

Warmest regards,


July 18, 2019 at 2:06 pm #4239517


Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Athlone,

First of all, sorry for not commenting on the "currencylayer". The same applies to "currencylayer" that accepts USD only as a currency base. If you can, as a test, change the base currency to the USD and see if the problem still persists with "currencylayer" or EUR with "". Probably this will update the currencies correctly.

I already tested both currencies. With, first I kept Euro as a base as well as USD using the "currencylayer" and it worked properly. As "Pound sterling", the same error message is displayed.

That is, in short: -> accepts only EUR as the base currency
Currencylayer -> accepts only USD as the base currency

Please note, unfortunately, this limitation is not by WPML. We only use a third-party service API.

If you can test with these currencies bases with the services posted above and the problem still persists, I'll be happy to check what may be happening on your site. Initially, this seems to be a limitation of the APIs.

Thank you.

July 29, 2019 at 5:20 am #4297061


Thank you for the reply.

I had to change the base currency from GBP to USD to get it to work. This was not ideal, perhaps this limitation should be clearly outlined in documentation to let anyone know that they cannot get updates when using GBP as the base currency.