This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Raja Mohammed 3 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
June 18, 2019 at 7:23 pm #4046241

timH-29

I am trying to: switch currencies on my WooCommerce product archive (Shop page)

Link to a page where the issue can be seen: hidden link

I expected to see: Currency switcher changes currency.

Instead, I got: In the production environment where WP Engine caching is enabled, the currency switcher reloads the page but does not change the currency. In the development environment, or when logged in, it works fine. This makes me think caching might be the problem. What cookies or arguments do we need to exclude from caching in order for the switcher to work? We do have "Store a language cookie to support language filtering for AJAX" enabled, but that is not solving the problem. Please note that right now currency switcher is hidden by CSS "display: none" because it is not working. I have also read that WP_memory_limit being low might cause this. Ours is at 40MB.

**EDIT: Just increased the wp_memory_limit to 256MB, and that did not solve the problem.

June 19, 2019 at 11:07 am #4051003

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for the detailed information, I have checked our internal documents, The issue with WP Engine and WooCommerce Multilingual Currency switcher is already fixed. We have not received any issues after the fix. Please check that your WooCoommerce Multilingual plugin is updated to the latest version 4.6.5, After the update purge the WPengine cache check if you can reproduce the issue. If the issue still persists Share with us the temporary access to your staging site I can check the issue with our developers.

Please let me know the results.

Kind regards
Raja

June 25, 2019 at 7:31 pm #4087003

timH-29

Hi Raja,

I'm just checking in after my last message to see if there's an update on this, or if you need any additional information. Thanks!

June 26, 2019 at 4:15 am #4088751

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Kindly apologize, For some reason, the ticket didn't appear in my queue and hence it's missed out, I am checking your issue now. I will keep you posted with an update.

Kind regards
Raja

June 26, 2019 at 6:00 am #4089205

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Please share temporary access to your production environment, Since everything seems to be working fine in the staging site it's better to check the production site.

It would be good if you can provide me with the WordPress debug.log (not WPML debug information).

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:


define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

Kind regards
Raja

June 28, 2019 at 2:26 pm #4108579

timH-29

Raja, I just sent a private reply. Sending this one too in case the private reply doesn't trigger a notice for you. Thanks!

July 1, 2019 at 12:47 pm #4119045

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks, I am able to access your production site. Since the issue is happening only with the shop page, Please try recreating the shop page, Delete and remove the page from trash and create a new shop page check if that helps.

I have requested advice from the second tier of supporters, I will keep you posted with any updates.

Kind regards
Raja

July 2, 2019 at 7:17 am #4124545

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for your patience, Our second tier supporter suggest to disable server-side cache which is disabled by default for the staging site and admin users and hence it works fine in both case. Try disabling the WPEngine cache check if that helps.

Let me know the results.

Kind regards
Raja

July 2, 2019 at 5:40 pm #4129177

timH-29

Hi Raja,

Thanks for this info. However, what we really need to know is what, specifically, to exclude from the cache. It's not really reasonable for us to disable caching on the entire site. As I asked in my first message, are there certain cookies or arguments we can exclude from caching in order for the switcher to work? Or do we have to exclude the entire page? We'd much prefer to exclude just the cookies or arguments we need to so the lack of caching doesn't slow down our site. Thanks, Tristan

July 3, 2019 at 4:50 am #4131785

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi tristan,

Thanks for the response, Sure I will try to help you with that.
I have seen a similar issue already escalated in our internal documents, for a similar issue.

WPEngine resolved it for a client by excluding the cookie with the name "wp_woocommerce_session_ "

Let me know if that helps you as well.

Kind regards
Raja