This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Oscar Miras 7 months ago.

Assigned support staff: Oscar Miras.

Author Posts
March 22, 2019 at 6:48 am

urdanetaZ

I have place on my TOP BAR the"Currency switcher and the Language Switcher"

In my HOME PAGE the Top Bar has a max width set by the 'Currency switcher and the Language Switcher" (26px).

hidden link

But when I go for example to some other page in the website with out changing the language or the currency, the "Currency Switcher" grows form 26px to 40px with out reason, and there for the whole top bar's width grows with it.

hidden link

I am not sure why is doing this.

March 22, 2019 at 4:17 pm #3442223

Oscar Miras

Hi,

Welcome to the WPML support team.

There was some extra margin added in the product page by the currency switcher.
I have added some CSS in Currency switcher options section in order to remove those margins. Now, it is displayed the same way either in the home page or in the product page.

In case you need to modify it again in the future, just go to WooCommerce > WooCommerce Multilingual. Open “Multi-currency” tab and scroll down to Currency Switcher options.

Do not hesitate to contact me again in case you have any further questions.

Kind regards,
Oscar.