This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Carlos Rojas 2 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 15, 2019 at 12:50 pm #4211093

mohammadA-31

I am trying to: view currency in current language

Link to a page where the issue can be seen:
hidden link
I expected to see:
JOD beside price field
Instead, I got:

July 15, 2019 at 3:08 pm #4212649

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Please try the suggested solution in this ticket: https://wpml.org/forums/topic/unable-to-translate-currency-using-wpml/

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

July 16, 2019 at 7:35 am #4217139

mohammadA-31

Hello,

we was increase memory size and add the function but still not work,

add_filter('woocommerce_currency_symbol', 'change_existing_currency_symbol', 20, 2);
function change_existing_currency_symbol( $currency_symbol, $currency ) {
switch( $currency ) {
case 'JOD':
if(ICL_LANGUAGE_CODE=='ar'){
$currency_symbol = 'دينار';
}else{
$currency_symbol = 'JOD';
}
break;
}
case 'د.ا':
if(ICL_LANGUAGE_CODE=='ar'){
$currency_symbol = 'دينار';
}else{
$currency_symbol = 'JOD';
}
break;
}
return $currency_symbol;
}

July 16, 2019 at 10:13 am #4218825

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

July 16, 2019 at 2:11 pm #4220893

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

I can see that you activated the multicurrency option but you haven't add any secondary currency yet. Please add a secondary currency or deactivate the multicurrency option in Woocommerce -> Woocommerce Multilingual -> Multi currency tab.

Could you tell me if the issue persists?

Best regards,
Carlos

July 16, 2019 at 2:22 pm #4220991

mohammadA-31

Hi,

we deactivate the multicurrency option, but the symbol was hide now in both arabic & english

Regards,

July 16, 2019 at 2:39 pm #4221129

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you for your feedback.

I would like to ask you to follow this steps:
- Go to Woocommerce -> Woocommerce Multilingual -> Status tab -> Fix all the problems that appear there.
- Check if the issue disappeared.

If the issue persists then follow this steps:
- Back up your site first before making any change, this is for security reasons.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Regards,
Carlos

July 17, 2019 at 2:14 pm #4231173

mohammadA-31

Hi,

still issue appears and give same error (the symbol hide in both languages)

July 17, 2019 at 2:16 pm #4231189

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you for your feedback.

I would like to ask your authorization to run some tests in the site. Please confirm that you have a full backup of the site to restore if needed.

Regards,
Carlos

July 17, 2019 at 2:21 pm #4231205

mohammadA-31

yes sure, you can do..
make note: the debug give this error

2019-07-17T13:49:06+00:00 CRITICAL method_exists(): The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition "WPML_LS_Template" of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide an autoloader to load the class definition /opt/lampp/htdocs/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-templates.php 304

July 17, 2019 at 3:16 pm #4231603

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your authorization.

I applied several tests in the site and now I can see this error message in the backend:
"WPML could not load configuration files, which your site needs."

Please apply the solution described in this link: https://wpml.org/errata/wpml-could-not-load-configuration-files-which-your-site-needs/

Also, I installed and activated Twenty Nineteen theme and the screenshot image kept the one from the Woodmart theme, which makes me believe there are more issues not related to WPML.

Could you tell me if the issue persists after the steps above?
Regards,
Carlos

July 18, 2019 at 6:32 am #4235257

mohammadA-31

Hello,
Thank you for feedback.
I have contacted the host and it is confirmed that the server has the required version of OpenSSL through cURL.
Please check the attached screenshot from the Site Health in the wp-admin

July 22, 2019 at 8:14 am #4254771

mohammadA-31

Hi
we do the migration, please check the problem and let me know
Regards

July 22, 2019 at 12:39 pm #4257285

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you for keeping me updated.

I visited the migrated site and after running several troubleshooting steps I found that the cause of the issue is not WPML, but Woocommerce itself. If you go to Woocommerce -> Settings -> Currency options -> The currency symbols are not there.

Please contact Woocommerce support service and ask them for a solution, they will be able to help you.

Best regards,
Carlos

July 23, 2019 at 10:19 am #4265057

mohammadA-31

Hi

but when we remove suggestion code the " د .ا" sympol