This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by Otto 1 month, 1 week ago.

Assigned support staff: Otto.

Author Posts
September 6, 2019 at 5:50 pm #4526995

lawrenceW-5

I am trying to: translate from English to multiple languages
hidden link

Link to a page where the issue can be seen:
New content showing as English, b/c the translation service didn't receive it
hidden link
Previous translated copy showing on this language b/c the translation update failed for this language: hidden link

To view pages on this dev server, please use "dev" as the username and "dev" as the password.

September 9, 2019 at 9:05 am #4534981

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly?

I'd like to gather information related to translation services you're using, along with checking communication logs and possibly escalate this case to our 2nd tier.

So just in short, you do the following, correct?
- take hidden link
- create a translation job and send it for translations ( to external translation service)
- the job gets rejected or canceled and you are unable to retrieve translations

Let me know if I missed anything.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

September 10, 2019 at 6:23 am #4542123

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

What email address can I use to set up your WordPress user account

You can use any email such as admin@example.com and put credentials into private reply. I set your next reply as private again.

Some of the languages were received by WPML

So in short, the problem is that for jobs "translations ready to download", they never download even though you try to sync them manually, while for others where the status is " completed", translations work properly on the front end?

As soon as you send me credentials, I will pass this case to our translation services specialist.

Regards,
Bruno Kos

September 10, 2019 at 1:22 pm #4545691

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

b/c a previous version of the content was sent for translation rather than the new content.

Now I fully understand it. A question - if you go to WPML -> translations and export XLIFF file of any of the pages in question, such as "K-12 EDUCATION", can you check inside the file whether new strings are there are only the old ones?

Also, have you tried creating a new job and checking then, what is within XLIFF then?

Regards,
Bruno Kos

September 10, 2019 at 6:19 pm #4548045

lawrenceW-5

Of the K-12 EDUCATION pages, I only see the one XLIFF which I manually opened after the translation was returned from translations.com. In that XLIFF there are only a handful of strings, it appears to be missing both old and new content somehow.

When you say "create a new job", do you mean resend K-12 EDUCATION for translation and assign myself as the translator to see the XLIFF? Or should I try a different page?

September 10, 2019 at 8:10 pm #4548777

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi,

I am Otto, from WPML Translation Services Support. I am in contact with your translation service and they asked me to take care of this ticket. I hope is OK with you.

I logged into the site and downloaded the translations for the K-12 page for French, German and Chinese.

Now all the jobs for that page are completed in WPML > Translation Dashboard.

But still, the actual content is not translated.

It looks like the content sent to translation was freezed with just a few blocks of the Avia builder content (Enfold), ignoring a bunch of text.

So, now that the jobs were completed, I made a small change in the original page (and reverted it). This made the WPML rescan the page and aware of the new content.

If you resend the content to your translation service, this time it will receive all the text available for translation.

Can you please try it? Resend the page to Translations.com and check with them if new content was received for translation. If so, after completing the translation, the whole page should appear translated in the front end.

Let me know how it goes, please.

Kind regards,

Otto

September 12, 2019 at 2:11 pm #4561577

lawrenceW-5

Thanks Otto, I will try today.

September 12, 2019 at 2:25 pm #4561699

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Thanks.

Let me know how it goes, please.

Kind regards,

Otto

September 12, 2019 at 8:18 pm #4564285

lawrenceW-5

It looks like the content has successfully sent. I'm having Christian at Translations.com review the other jobs I've sent over to make sure we don't have a similar issue elsewhere.

September 13, 2019 at 11:52 am #4568199

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Great, let me know if you need anything else on our side, please.

Kind regards,

Otto