Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Bigul 10 months, 4 weeks ago.

Assigned support staff: Bigul.

Author Posts
July 20, 2020 at 6:15 pm #6637731

borja-alonsoL

Tell us what you are trying to do?
- Our add to cart buttons have non-standard woocommerce text. They say in Spanish "lo quiero" (I want it" instead of "add to cart"). I have searched for the string "lo quiero" and translated all available for translation but on the English version it´s still appearing "Lo quiero" unstranslated

Is there any documentation that you are following?
No, I just translated the string using the string translation tool

Is there a similar example that we can see?
No, it´s just with the woocommerce buttons. Actually, the shop page have buttons showing "I want it" but they are "normal" buttons with a simple link which were translated along the other page text, not woocommerce add to cart ones.
The English language is hidden so I can provide admin user with access granted.

What is the link to your site?
hidden link

July 21, 2020 at 10:16 am #6642103

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

Have you added the string *¡LO QUIERO!* via the admin options(on the backend)? If so, may you have to find and add the string for translation from WPML>>String Translation>>Translate texts in admin screens page. Please refer to the following documentation URLs for more details.

https://wpml.org/documentation/getting-started-guide/theme-localization/translating-options-coming-from-themes-and-plugins/

https://wpml.org/documentation/getting-started-guide/translating-theme-options/

Also, please enable the *Look for strings while pages are rendered* option of WPML>>String Translation>>Auto register strings for translation(on the bottom of the page). Then visit the Shop page and check it is showing the expected result. This option will be disabled automatically after couple of hours. But will help us to track the issue.

I have a request. Please upgrade the following configuration for the better performance of the site.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://wordpress.org/support/article/editing-wp-config-php/#increasing-memory-allocated-to-php

2) Increase the *MaxInputVars* of PHP settings to *5000* or more. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

--
Thanks!

Bigul

The topic ‘[Closed] Custom add to cart buttons not translated’ is closed to new replies.