Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by mmoI 1 week ago.

Assigned support staff: Sumit.

Author Posts
November 22, 2018 at 10:29 am #2929916

mmoI

Hello,

I have one problem with Custom attributes when I export/import the Xliff file. I explaine you. the Xliff export work well (all fields appear), but when I import the Xliff, the Attributs Titles translation aren't appear. Only the Attributs Values appear.

Can you tell me how I can make for the Attributs Titles translation appear when I import Xliff file ?

Thanks

November 26, 2018 at 1:29 pm #2940288

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for contacting support forum.

There is a known issue with the simple product and custom attribute where XLIFF file does not contain the attribute values in the file.
Could you please let me know if you have this issue with the simple product or variable product?

If this a variable product then please make sure you are having correct formatting of XLIFF file (not broken syntax)

I am assuming that you are checking the title on front-end could you please check the title at the backend by switching to the native interface? Do you see the translated content?

Please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here: http://wpml.org/faq/provide-debug-information-faster-support/

Thanks

December 4, 2018 at 9:15 am #2965451

mmoI

Hello,

Yes it's with Simple Product, I have this problem only on "Custom attribute product" (when we add manually title and parameter/content). Please see attachment.

No, I don't see the title translation in front-end and back-end (please see attachment : 2018.12.04_Title of Custom attributes_Xliff file_front-end ; 2018.12.04_Title of Custom attributes_Xliff file_back-end)

.xliff file imported: hidden link

Debug Information: hidden link

Thanks

December 4, 2018 at 2:45 pm #2966954

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thanks for the information. I see variation description in XLIFF file whereas it is a simple product. So I guess the job data is not updated yet.
Could you please update the product (just click update without making any change) in the main language and then resend the job again and then export/import the XLIFF file. Does it work?

Thanks

December 11, 2018 at 10:51 am #2988225

mmoI

Hello,

I tested your advice and it doesn't change anything. Have you other idea ?

Thanks

December 11, 2018 at 7:40 pm #2990192

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, this is Ahmed Ibrahim and I will continue with you since Sumit is off.

Could you please provide me with temporary access (wp-admin and FTP) to your site in order to provide a better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

+ Please make sure that you have a full backup of your website and database. (Please don't ignore this)!
+ It'd be great if you give me an access for a test site where the problem is replicated.

Best Regards.

December 12, 2018 at 11:12 am #2993006

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I can see that you have opened another ticket for the same issue here: https://wpml.org/forums/topic/custom-attributes-xliff-file/

So we can continue here, just to let you know that we have a known issue with simple products related to what you mentioned and will be fixed at the next WCML release, so I want you to try the following workaround:
please go to this file: wp-content/plugins/woocommerce-multilingual/inc/class-wcml-tp-support.php at line:47
and change the line from being:

            if ( ! empty( $product ) && $product_type === 'variable' ) {

to be:

if ( ! empty( $product ) && $product_type === 'variable' || $product_type === 'simple' ) {

Then please remove any cache on the site, and create a new test product, and check if you can replicate the issue with the new product.

Please let me know if that helps you.
Best regards.

December 17, 2018 at 2:55 pm #3008860

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I am sorry for the delay. Ok, I do understand now. We were suspecting the previous issue but this is an edge case of the previous issue when importing back the XLIFF file. I hope I am right?

I am checking this now and I will update you soon.

Thanks

December 17, 2018 at 4:33 pm #3009436

mmoI

Hi,

Yes it's another issue, you right.

Thanks

December 18, 2018 at 1:27 pm #3012371

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I can replicate this issue and I have escalated this. I will keep you posted about the status of this issue.

Thanks

January 3, 2019 at 9:45 am #3051784

mmoI

Hello,
I come to news. Where are you with this ?
Thanks

January 3, 2019 at 2:56 pm #3053313

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

The issue has been fixed and in testing state. It is scheduled to release in the next WCML version.
I am sorry it is taking some time but I will update you as soon as it is available to download.

Thanks

December 3, 2019 at 8:31 am #5058337

mmoI

My issue is resolved now. Thank you!