This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.12 hours from now. Thank you for your understanding.

This topic contains 13 replies, has 2 voices.

Last updated by Itamar 1 month ago.

Assigned support staff: Itamar.

Author Posts
June 4, 2018 at 10:21 am #2268110

adrianF-7

Hello Support Team,

I created a WYSIWYG custom field for WooCommerce products using Toolset Types, but when I'm trying to translate the field it's appearing as input type text in the Translation Management. So it's very difficult to translate.

Kindly help me out with any solution for this.

Thanks

June 5, 2018 at 6:33 pm #2276923

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Thank you for contacting the WPML support forum.

When I look at the debug information that you have shared with us I can see that the Toolset Types plugin is not updated to its latest version.
Could update the Types plugin and check if the issue persists?

If it does persist, could you please share with me the exact steps on how I can replicate the issue?
Sometimes screen-shots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.
Then I'll be able to test it on a clean WordPress installation on my local server.

Thanks,
Itamar.

June 5, 2018 at 7:41 pm #2277213

adrianF-7

Hi,

When I try to update the toolset I get "Toolset Types cannot update because your site's registration is not valid. Please register Toolset again for this site first.", I think is a temporary bug because they have already said that they'll provide update to toolset till 2018 end.

I can mention the steps to replicate:
1) Go to Toolset -> Post Field and create a new Group and select "Products" in "Where to include this Field Group" option.
2) Add a field to the newly crated group and select WYSIWYG as field type.
3) Select Translate in Translation preferences field.
4) Create a new WooCommerce product, and fill any data in the custom field created and publish.
5) Click on translate product and the field will be displayed as single line field in the translation manager.

Thanks

June 6, 2018 at 4:22 am #2277933

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the extra details.

When I try to install the Types plugin on my test site, I can see in that there is a problem.
I get the following message: "Installation failed: Installation package not available."
I've informed this to our system people, and I'll keep you updated here about this issue.

In any case, I've tried the issue on my local server following the instructions that you gave me.
I get the results that you report. For the custom field that I created I get a single line in the Translation Editor with no option to edit it as a WYSIWYG. Please see attached screenshot.
Is this how you see also?
If so then it might be that this is the expected behavior when it comes to custom fields.
I'm consulting our second tier supporter about this issue.
But I also wait for your reply if this is indeed the issue.

Thanks,
Itamar.

June 6, 2018 at 9:00 pm #2311724

adrianF-7

Hi,

Thanks for following the steps, I'm also getting the field same as your screenshot.
Kindly keep me updated when you have a solution.

Thanks

June 7, 2018 at 4:21 pm #2397263

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'll keep you update on this. I'm still waiting for an answer from our developrs about this issue.

Thank you for your patience.

Itamar.

June 10, 2018 at 9:45 am #2403325

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and sorry for the late response here.

This issue is only happening when you assign the field group to 'Products'.
It is not happening if you assign it to regular 'Posts'.
I've escalated this issue now, and my supporters will check it.
Beda has also discussed this issue with me, and I'm aware of your discussion here.
https://wordpress.org/support/topic/help-with-wpml-and-wpbakery-page-builder-integration/

We'll keep you updated about this issue here in this ticket.
Thank you for reporting it.

Best Regards,
Itamar.

June 10, 2018 at 9:47 am #2403326

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Changing the status to 'Escalated to 2nd tier'

June 10, 2018 at 9:53 am #2403328

adrianF-7

Ok, thanks for the update, kindly let me know when there's any resolution for this.

June 10, 2018 at 10:18 am #2403338

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Sure I'll keep you updated here.

June 18, 2018 at 11:41 am #2418946

adrianF-7

Hello,

Is there any update on this?

Thanks

June 18, 2018 at 11:57 am #2418985

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

The issue is escalated to our developers.
I'll keep you updated here.

Thanks,
Itamar.

August 12, 2019 at 2:10 pm #4381523

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

This issue will be fixed with the next version of WooCommerce Multilingual.

Regards,
Itamar.

September 15, 2019 at 9:12 am #4574217

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

This issue is fixed with WooCommerce Multilingual version 4.6.7.
https://wordpress.org/plugins/woocommerce-multilingual/

Please let me know if it is working for you.

Regards,
Itamar.