This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Riffaz 2 months, 3 weeks ago.

Assigned support staff: Riffaz.

Author Posts
July 5, 2019 at 4:33 pm #4152911

Greatives Team

Hello,

I am trying to translate a custom field via Translator Editor but field is not available in the other languages via Translator Editor. The custom field is configured correctly as translate in wpml-config.xml.

The issue is reproduced when value of the field is a number, using a text seems to work fine.

Is there a restriction there?

I expected to see the custom field as it is already set as action="translate" in wpml-config.xml

Thanks in advance!

Thanasis

July 7, 2019 at 6:25 am #4157233

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

If you go to WPML » Settings and then "Custom Fields Translation," what do you selected there?

Also, please provide the debug info for better and faster support: https://wpml.org/faq/provide-debug-information-faster-support/
I am enabling the debug info for this ticket.

Regards,
Riffaz.

July 7, 2019 at 7:46 am #4157353

Greatives Team

Hello Riffaz,

Maybe my question was not clear enough.

Normally i can translate any custom field, it seems that if the value of the custom field is a number this cannot be achievable via Advanced Translation Editor / Classic Translation Editor

e.g: translates correctly value: sample text, cannot translate: 500

If i don't use translation management ( manually translate ), thene it works also with numbers.

Thanks in advance!

July 8, 2019 at 9:17 am #4160495

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

It all depends on the number, if it's an ID for example it should appear but it could be a bug on our end as well!
I checked with the team.
We need to check this in a fresh installation.

please,
1. go to hidden link
2. install ACF
3. configure the WPML as you have it on your site. at the last step just click next (site key)
4. create only one page with element/fileds you are creating using ACF
5. recreate the issue.
6. let us know how to check this and how to recreate this issue.
7. explain the step 6 with screenshots and URLs for better understanding.

Regards,

July 8, 2019 at 10:27 am #4161283

Greatives Team

Hello,

Yes exactly the value is actually an ID in a select box. The custom field is defined in wpml-config.xml of the theme.

I tried to simulate the scenario in your sandbox installation. I think it's easily reproduced. I tested the Classic Editor first. You can see the results in the Sample Page

I attached some screenshots to help you out. I believe the same result is in Advanced Editor.

Regards

July 8, 2019 at 11:12 am #4161693

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

I escalated this to our second tier.
Please be patient till we get back to you.

Regards,

July 9, 2019 at 7:18 am #4167937

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I just noticed that you are not using "Advanced Custom Fields Multi Lingual" glue plugin.

Please install ACFML and try to translate.
Please refer : https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Let me know how it goes.

Regards,
Riffaz.

July 9, 2019 at 7:54 am #4168263

Greatives Team

Hello,

I think you missed completely the original scenario, i'll try to explain again.

I'm not using ACF at all. The custom field i'm trying to translate is defined in wpml-config.xml of the theme. The field is set correctly as translate in wpml-config.xml.
I used ACF as you suggested only to simulate the problem.

Anyway maybe i have reached the wrong forum. As the issue is related to settings defined in a theme.

Is there any other way to communicate this with a WPML developer via this forum, chat or otherwise?

Thanks in advance!

July 9, 2019 at 12:29 pm #4170697

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Ok, thank you.

Our second tier support is checking the issue.
Please be patient till we get back to you again.

Regards,

July 22, 2019 at 12:07 pm #4256941

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for your patient.

Second tier replied:
This was built like this purposely.
Numbers as same in all the languages.
Numbers no need to be translated from FR to En or vice versa.
So this feature is not included in WPML.

Please make a feature request for this here: https://wpml.org/suggest-a-new-feature-for-wpml/
So our developers will consider adding this in future versions.

Regards,
Riffaz.