This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by dirkV-9 5 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 2, 2019 at 3:41 pm #3726191

dirkV-9

I am trying to: Make translations of single- productions. When I try to start a translation it shows the copied custom fields, but the translation only shows when the translation is 100% complete. Then all copied custom fields (like sliders, etc) are gone.

Link to a page where the issue can be seen: hidden link and the German page is then hidden link

I have followed many threads and tried a lot but, I still get the same result over and over again...
Any suggestions?
kind regards, Dirk

May 2, 2019 at 7:37 pm #3728835

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

May 3, 2019 at 10:28 pm #3738247

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. Please, try the following:

1 - Make sure your custom fields are defined as 'copy' so the post contents can be replicated to your translations. See: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

2 - Now instead of using the WPML Translation Editor to translate your post content, please, make sure you are using the WordPress default post/page editor, this way you will be able to see your custom fields content in the same screen of your default language page. See: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

Please, let me know if any additional clarifications are needed. Have a nice day.

May 6, 2019 at 7:32 am #3745471

dirkV-9

Hello Marcos,

the suggested steps don't work... have you checked them yourself, or am I missing something?
I even can not find the option to duplicate the pages. I have to finish the website the coming days. Any new suggestions?

kind regards,
Dirk

May 6, 2019 at 8:10 am #3745745

dirkV-9

I also saw I cannot set the form fields to translatable...
kind regards, Dirk

May 7, 2019 at 8:48 pm #3761941

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a further look in your website and notice your 'Project details' fields group doesn't have a german translation yet, this is why you don't see the defined 'Project details' when editing the german 'production' post. Please, add a translation for this field group and try to edit the translated 'production' post again. Here are the full details:

1 - In your WordPress Dashboard > Custom Fields > Fields Groups click to edit the 'Project Details' group.

2 - In the language box from the group editing screen click to add a duplication for the german language.

3 - Now you should be able to see the 'Project Details' field group for your german language too.

See: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Please, let me know if you still need further clarificaitions and additional instructions. Have a nice day.

May 8, 2019 at 12:11 pm #3766477

dirkV-9

My issue is resolved now. Thank you!