This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Dennis 2 months, 2 weeks ago.

Assigned support staff: Dennis.

Author Posts
July 23, 2019 at 10:37 pm

jensL-15

Just recognized, when translating a site, the custom fields are not there for the second language. On pages and post already created everything is still there. It just happens with new post objects.

July 24, 2019 at 7:48 am #4271131

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Could you please share your Debug information with me? You can read the detailed explanation about it here.

http://wpml.org/faq/provide-debug-information-faster-support

The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

I tried to access your site but for some reason, the credentials does not work on end. Could you please check? I will enable the access information box for you and make your next reply as private.

Kind regards,
Dennis

July 24, 2019 at 8:01 am
July 24, 2019 at 9:34 am #4272455

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

It seems that you lacked WPML String Translation and Translation Management plugins. Both plugins are required for translating sites built with ACF.

Please review our documentation here:

https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

requirements:
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#requirements-and-installation

Hope this helps.

Kind regards,
Dennis

July 24, 2019 at 10:49 am #4273533

jensL-15

Hey thanks anyway but still if I set up a translation or even just a new page in the secondary language(EN) no custom fields are visible for that page or post. Did I miss something general while creating the ACFs? It worked a while ago, just created an ACF and it would appear both for primary and secondary language pages?.

THX

July 25, 2019 at 3:30 am #4278973

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

It could be that your fields inside the field groups are not set to 'Translate'. Could you please check the fields' 'Translation preference' is set to 'Translate'. After setting, translate the page again.

Kind regards,
Dennis

July 25, 2019 at 7:27 am #4280035

jensL-15

I've added a field group test and changed it from do nothing to translate but still nothings appears, when you translate a page. Any ideas? I'm getting pretty desperate and so is the client. Thanks

July 25, 2019 at 9:36 am #4281387

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

I made a test page on your site. First, I edited the 'Info Pages' field group and set each field to 'Translate'. Then, I created a page with 'Info pages' as template and translate it completely. It seems work for me.

here's the page I created:
hidden link

Kind regards,
Dennis

July 25, 2019 at 12:28 pm #4283061

jensL-15

Hey Dennis,

I see what you mean, but the problem is, that it only works, when I use the WPML-Translation online, but I need the custom fields to be visible in the English(Secondary) Back-End if I choose to make the translation in the editor? If that is not possible, how can I go back to a state, where there is no Copy/Translation feature but only basic connected pages/posts with ACFs?

July 26, 2019 at 7:50 am #4288007

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for clarification. I was now able to reproduce the issue on your site.

Could you please check if this issue appears when:

-You deactivate all non-WPML plugins, except the plugins required to debug.
- Theme is set to a WordPress default like Twenty Sixteen. Its will tell us if there is an interaction issue with your theme.
- If the problem disappears, start activating one at the time to track where the incompatibility is produced.

Note: Please backup your site completely before doing this test. Or conduct this test on a staging site.

Please let me know your results.

Kind regards,
Dennis

The topic ‘[Closed] Custom Fields do no longer appear when translating a page or post’ is closed to new replies.