This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by Andrés 1 year ago.

Assigned support staff: Andrés.

Author Posts
October 2, 2018 at 12:10 pm #2781342

Adriano

Ciao Andrés,

unfortunately I still have problems to translate the pages, some elements are not duplicated on other pages.

I already had this kind of problem in those topic https://wpml.org/forums/topic/duplicating-the-pages-keeping-the-layout/ and https://wpml.org/forums/topic/translation-problems-2/

The home page hidden link appears differently in the following languages:

October 2, 2018 at 3:16 pm #2782019

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Adriano, 🙂

That's pretty strange as these pages were already translated. Let's check your slider issue first. I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue. Could you please indicate me how to replicate this behavior?

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

*Important: Be sure to backup your site and database first before you proceed!
You can use a plugin for this if you like. You can use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

If you don't see the form below, pelase don't add your credentials as they will be publicly exposed:
hidden link

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Best regards,
Andrés

October 3, 2018 at 10:58 am #2784255

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Thank you for your credentials, Adriano. As you know, we can handle only one issue at the time and I started with the slider on your Spanish site. It seems that this is caused to your theme upagre and maybe your cache system.

Your slider setting, _et_page_slider, can't be set as "copy" and that's why it is nos showing in ES. By the way, it shouldn't be show in any language but Italian.

I'll continue on it and get back with news latter.

October 3, 2018 at 11:40 am #2784392

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

It seems that I was right and with your theme upgrade the _et_page_slider setting was change to "Don't transalte". After temporary deactivating the Memcached, I could set it right and know the sliders is being show in all languages. However it seems that the slider is not translated yet, am I wrong?

October 4, 2018 at 12:20 pm #2787455

Adriano

Thank you as always for the precious help you give me!

Now I see the sliders on all the pages, but in the German and Russian I see 2 sliders.

You're right, the sliders are not translated because if I translate them I lose the settings (font, layout, images).

October 4, 2018 at 12:36 pm #2787496

Adriano

I noticed that even the pictures of the paragraphs on the page in German and Russian are not seen.

Also on the wordpress dashbord I have the following notice:

We have detected a problem with some tables in the database. Please contact WPML support to get this fixed.

Array
(
    [language] => it
    [context] => admin_texts_woocommerce_checkout_privacy_policy_text
    [gettext_context] => 
    [domain_name_context_md5] => 106e58cace47e81f348a021d1b703e4b
    [name] => woocommerce_checkout_privacy_policy_text
    [value] => Your personal data will be used to process your order, support your experience throughout this website, and for other purposes described in our [privacy_policy].
    [status] => 0
    [translation_priority] => optional
    [allow_empty_value] => 1
)
October 4, 2018 at 2:00 pm #2787747

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hey Adriano, 🙂

I repeated the same process for your other pages than for Spanish and now they are displaying only 1 slider per page. Could you please give it a look?

Regards

October 5, 2018 at 11:40 am #2790576

Adriano

Andrés thank you very much for your help, now I can visualize everything perfectly.

I have only one question, changing the text or adding elements will still have problems?

I have a similar problem on the contact pages, I have modified the map, but it does not appear updated in the English - French - German - Russian language.

October 5, 2018 at 2:10 pm #2791070

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Ciao Adriano,

Every time that you change your original page, you need to resave your translations in order to add these modifications into your translation as well.

If this is not happening, please check and remove your cache and try to re-save again. If after this, the changes are still not visible, don't hesitate to open a new ticket, I'll be happy to investigate it.

Regards,
Andrés

October 6, 2018 at 3:49 pm #2792948
Adriano

Hey Andrés,

I have a problem in the contact pages, I have modified the map on the Italian page.

I have:
- re-save again and again the translations of all the other languages
- purge SG cache
- clean the browser
- waited 2 days for the changes to take effect

but the map changes are not updated in the languages: English - French - German - Russian.

I'd like to understand where I'm wrong 🙁

New threads created by Andrés and linked to this one are listed below:

https://wpml.org/forums/topic/split-custom-fields-translation/

October 6, 2018 at 4:08 pm #2792956

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Adriano,

I had to create a new ticket as it is a different issue.
Let's continue there. 🙂

Regards,
Andrés

October 9, 2018 at 2:45 pm #2800530

Adriano

Ciao Andrés,

I'm having the same problem of images that are not displayed on the pages hidden link

1. the images are not displayed in:

  • hidden link;
  • hidden link;
  • hidden link;

2. furthermore, when I updated the translation, there were no references to all the paragraphs of the translations even if I had already translated them months ago.

I have invited Olga, 8theme's assistance service, to solve this problem of non-translatable elements that are not displayed in other languages, I hope it's not a problem.

Best regards,
Adriano

October 9, 2018 at 3:01 pm #2800653

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Ciao Adriano,

Of course it is not a problem! 🙂

However, we have handle several issues on this ticket and it would be good to open a new one to avoid confusions.

I just checked this situation and it seems that it is the same than one of the other tickets we have handle recently and it is that you have made some changes on the original page.

For solving it, you have to go to your translations and assure that they are at 100% translated. I just did it for German which was at 98% and after that all the images were displayed correctly.

Can you do the same for your other languages?

Regards,
Andrés

October 11, 2018 at 11:56 am #2808023

Adriano

Ciao Andrés,

the only change I made in the Italian page is to replace the images, so I do not understand why the translations are no longer translated 100%.

Moreover, the checkmarks on the paragraphs already translated in the past are no longer present. Is it normal that by modifying only one element, such as the image or the slide, the already translated paragraphs are also deselected?

Unfortunately I can not always translate a page to 100%, usually does not translate immediately I paragraph Yoast SEO, in this case the rest of the translations will be visible?

Regards,
Adriano

October 11, 2018 at 12:20 pm #2808089

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hey Adriano, 🙂

That's why the images disappeared and why it was necessary to mark the translation to the 100%. Once you do it, the translation is updated and the images reappeared.

In case you can't translate a paragraph, you can copy the original content and then check the checkbox, once you do it, everything will work correctly.

Does it help?

Ciao!
Andrés