This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Noman 5 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
May 5, 2019 at 8:43 am #3742119

tamerA-2

I am trying to:
Change my ar flag to ae.png
Link to a page where the issue can be seen:
WPML>Languages>Edit Language
I expected to see:
The new ae.png flag
Instead, I got:
default green flag

May 5, 2019 at 10:36 am #3742407

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

- Please make sure minimum requirements for WPML meet:
https://wpml.org/home/minimum-requirements/

- Please make sure you are using an updated version of the theme and plugins.

- Please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

- Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

- If still issue persists, please enable error reporting at you site as I need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/
https://codex.wordpress.org/Debugging_in_WordPress

To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

define( 'SCRIPT_DEBUG', true );

After adding above code please try to reproduce the issue and this will create debug.log file in your site's wp-content directory. Please send me its contents.

Thank you

May 5, 2019 at 11:14 am #3742443

tamerA-2

I have provided my Debug info, there was no WP_DEBUG', true in my wp-config.php so I added them

May 5, 2019 at 11:36 am #3742477

tamerA-2

After adding above code I tried to change the icon again but I got nothing just as before and there is no debug.log file created in wp-content directory

May 5, 2019 at 11:42 am #3742555

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for providing debug info. Could you please follow below steps and let me know how it goes?

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

=== Please backup your database and website ===

2. Please upgrade your server’s PHP version to a higher level: https://wpml.org/home/minimum-requirements/

- PHP is 5.6.35 which is good, but it's advised is to use more up-to-date version for better performance and stability. You can contact your website hosting company to upgrade this for you.

3. You are using older version of WordPress on your site, please backup your site and update WordPress to it’s latest version 5.1.1.

Thank you

May 5, 2019 at 11:48 am #3742571

tamerA-2

BTW, this is what I get when I try to change the Arabic flag

May 5, 2019 at 11:51 am #3742601

tamerA-2

And this is my site info now after increasing the wp memory limit

May 5, 2019 at 2:23 pm #3743009

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

The topic ‘[Closed] Custom flag is not working!!’ is closed to new replies.