Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 3 voices.

Last updated by davidD-3 10 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
January 18, 2019 at 2:39 pm #3106393

davidD-3

My website is built with OceanWP theme and Elementor.
I did a custom header which is choosen in the Theme Customizer, and it is registered in the Theme Panel/My Library of OceanWP.
This custom header is build with Elementor and I translated as all the website's pages using the WPML Translation Editor.
In WPML setting/Post Types Translation, I have setup the “My Library (oceanwp_library)“ translatable. Same for the “ocean_custom_header_template“ in the WPML setting/Custom Fields Translation.
But the header remains in the default language (French) on the english pages. You can see it there: hidden link (the header contains only the logo, a search field plus 2 buttons that are not translated).
Thanks for your help.
Best,

David

January 18, 2019 at 3:21 pm #3106674

davidD-3

More info:
Only the search field is translated and its the native WP widget which displays a dropdown menu to select the languages (all, french, english).
The logo has a link to the english page but it doesn't work too.

January 18, 2019 at 8:14 pm #3107224

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

January 21, 2019 at 8:29 pm #3113975

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and sorry for the bit of waiting here, we are experience some stability issues on our servers which might delay our replies, our team are working hard to make things back to normal again. I tried all the settings possible in your website, still no success in making the translated header to appear, this is why I need to take a step further in the investigation process, for that, please, consider:

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Thank you for your collaboration. Have a nice day.

January 21, 2019 at 8:32 pm #3113984

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, check my private reply above, thanks!

January 22, 2019 at 9:03 am #3115259

davidD-3

Hi Marcos,
I saw your problem art WPML. Sorry for that.
I have deleted your account and created a new one. Do you stil need it? How can I sent you the access info?
I also created a Duplicator archive. Here is the link on my own host (I'm not using Dropbox).
Best,

David

January 23, 2019 at 4:30 pm #3121672

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello David,

Thank you for the updates and sorry for the bit of waiting here. I still need the new created access details, also, please, provide me with the duplicator package download link. I will enable the private reply fields again, so you can safely send these details. Thank you for your collaboration, have a nice day.

January 24, 2019 at 10:08 pm #3127187

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I replicated the exact same issue in my local installation, I need some extra time to keep troubleshooting this issue in order to identify the cause of it. Thank you for your continued patience, I will do my best to provide you with a detailed reply soon. Have a nice day.

January 25, 2019 at 8:02 am #3128078

davidD-3

Hi Marcos,
I need a solution, so I'll be patient.
Best,
David

January 25, 2019 at 3:59 pm #3129747

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Since Marcos currently has a few days off, I will replace him here in the forum. I hope this is OK for you.

As this seems to be a compatibility issue with the OceanWP theme, we need to follow these procedures:
- Install the theme in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
- After this, I will check the problem in this new installation and look for a quick solution
- If I can not find a solution, I will forward the problem to our compatibility team
- The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the theme to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the theme and the related functionality, you don't need to setup a entire website or clone your existing site.

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests.

Kind regards,
Diego

January 25, 2019 at 6:02 pm #3130195

davidD-3

Hi Diego,

I don't really understand.
Marcos asked me to give ftp and admin access. He also asked me to make a copy of my site with Duplicator, you tested it and reproduce the problem in your local copy.

Why do you need me to reproduce all this in a new test site? With the duplication you've got everything to test and to reproduce the same parameters in your clean test website. Why do you want me to do all this?

The theme is OceanWP, supposed to be fully compatible with WPML (see that: https://wpml.org/2018/02/oceanwp-theme-and-its-premium-extensions-are-now-wpml-compatible/).

As I wrote in my first post, I used the custom header function of the theme. And I create this custom header with Elementor. So I create a test page (hidden link) in which I included the section used in the header.
You can see the texts are well translated in this case. Both for the section in the page and the section in the header.
But this is the only page here this header is translated.

It is sure that there is a problem with the theme and its custom header function. You can easily reproduce the same thing in any clean website.
What do you want me do to more than this?

Best,

David

January 29, 2019 at 2:25 am #3137907

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your patience while waiting for a solution for your issue. As Diego said it seems to be a new compatibility issue between WPML and the OceanWP theme, this is why I forwarded your ticket to our compatibility team, so they can provide you with a workaround and contact the author regarding this issue. I will update you here as soon as I have a reply from them. Thank you for your continued patience and understanding, have a nice day.

January 29, 2019 at 8:19 am #3138510

davidD-3

Hi Marcos,
Thanks for your reply and your explanation. I'll wait.
Best,
David

January 31, 2019 at 5:58 pm #3149152

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello David,

Thank you for your continued patience while waiting for a solution. I am still waiting a reply from the compatibility team, I will update you as soon as they provide a detailed reply. Thank you for your understanding, have a nice day.

February 13, 2019 at 3:22 am #3191831

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello David,

Thank you for your patience while waiting for a solution. I got some more info regarding your issue, we tried to replicate it in a clean sandbox install and the issue is not being replicated as you can see at: hidden link, here are the steps we tried:

1 - In the WordPress Dashboard > WPML > Settings > Post Types Translation we set the 'My Library (oceanwp_library)'</srong>as translatable.

2 - We created a custom header and translated it (note that the translation shortcode has a different ID).

3 - In the WordPress Dashboard >WPML > String translation we entered the ID of the translated header for the option '[theme_mods_oceanwp]ocean_header_template' under the text domain 'admin_texts_theme_mods_oceanwp'.

Basically, this seem to be the same steps you tried in your WordPress installation, however a compatibility issue wasn't confirmed in our tests in a sandbox environment, your issue in this case has another cause, maybe a cache issue, plugin conflict or so, I would recommend:

1 - Clear any cache you might have, browser cache, server cache, etc.

2 - Disable all the plugins not directly related with your theme or the WPML itself.

3 - Create a test header and translate it.

Please, let me know the results, have a nice day.