This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Custom html widget is not visible or Display Widget plugin does not work

Solution: The issue has been reported to the plugin other a few times: 1. https://strategy11.com/display-widgets/#comment-108 2. https://strategy11.com/display-widgets/#comment-123

This will take a lot of time to troubleshoot and to create the fix. And, spending sources on a discontinued plugin is meaningless.

This one is similar to Widget Logic if you want you can try: https://wordpress.org/plugins/widget-logic/

This topic contains 6 replies, has 2 voices.

Last updated by maciejB-14 4 months, 4 weeks ago.

Assigned support staff: Riffaz.

Author Posts
May 20, 2019 at 12:45 pm #3846877

maciejB-14

I am trying to: translate custom html widget with my own menu but the widget is not visible on the page.

Link to a page where the issue can be seen: hidden link (this is my test page I have three custom html widget with own menu)

on the right page I have custom_html widget like on this page hidden link

I expected to see: hidden link

Instead, I got:no visible custom html widget

May 20, 2019 at 12:59 pm #3847017

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Do you use this plugin Advanced Menu Widget, or any other plugin to create this HTML widgets?

Let me know.

Regards,
Riffaz.

May 20, 2019 at 2:18 pm #3847855

maciejB-14

Hi.
I use plugin Advanced Menu Widget but this widget works correctly. For three subpages I use wordpress html custom widget with my html code, please see on image: custom_html widget.png (is not visible). In string translation the translation is finish: second image. I think that I must translating something more but I don't know what I think?

Regards,
Paweł

May 21, 2019 at 6:51 am #3852367

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Ok, I got it now.

You are having the same issue that explained in this ticket: https://wpml.org/forums/topic/error-sidebar/
Please try the suggested solution in that ticket.

Let me know how it goes.

Regards,
Riffaz.

May 21, 2019 at 2:19 pm #3856121

maciejB-14

Hi,
I disable plugin display-widget and install plugin widget options. And for now in polisch language I see correct widget:
hidden link
but in english version is not visible but is visible widget advanced menu (I chceck box too hide on this page)
hidden link
That I must translate whole 400 string from widget-options? to see in english version my html widget?

May 22, 2019 at 7:41 am #3862625

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Ok, then it might be a compatible issue.
We need to check this in a fresh installation.

please,
1. go to hidden link
2. install your theme
3. Install the plugin
4. configure the WPML as you have it on your site. at the last step just click next (site key)
5. add the widget and set it as you want
6. create only one page and translate it.Then add the widgets as per the language.
7. recreate the issue.
8. let us know how to check this and how to recreate this issue.
9. explain the step 8 with screenshots and URLs for better understanding.

Regards,

May 23, 2019 at 10:36 am #3873789

maciejB-14

Hi,

Finally I uninstalled the widget display-widget (I think it's not compatible with WPML) and installed the widget widget-options instead, then I deactivated the advanced-menu plug-in and translated the page again with an additional side menu, then activated the advanced-menu plugin and then I had the option of choosing in my custom-html widget to choose from pages to choose from for language reasons. The last thing started working.

My issue is resolved now. Thank you!

Regards,
Paweł