This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Дмитрий Яблонский 3 months, 2 weeks ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
July 2, 2019 at 6:57 am #4124393

Дмитрий Яблонский

Tell us what you are trying to do?
-------------

Hi, 1) I setup Custom language sweetcher (screen 1)

2) Insert shortcode [wpml_language_selector_widget] in my site hidden link

Current language show, but dropdown not expant while hover

July 2, 2019 at 10:20 am #4125701

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for contacting WPML Support.

I see that your theme defines some styles for the widgets that cause this issue on the language selector. The issue is on this CSS code (in the file: /wp-content/uploads/jupiterx/compiler/jupiterx/style.css):

.jupiterx-widget {
    margin-bottom: 1.5rem;
    font-size: .875rem;
    overflow: hidden;
    list-style: none;
}

The problem is that the overflow is set to hidden, so the selector is not displayed entirely when its longer than its specified height.

The best way to fix it would be to add some additional styles. You can add this line of code on any of your CSS stylesheets or directly from the admin panel by navigating to
WPML > Languages > Language switcher options > Additional CSS :

.jupiterx-widget.widget_custom_html {
    overflow: visible;
}

Let me know if you're able to see the entire language selector after applying this quick fix.

Thanks,
Rohan

July 4, 2019 at 5:03 pm #4145471

Дмитрий Яблонский

Thank you )