This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Lauren 1 year ago.

Assigned support staff: Lauren.

Author Posts
September 21, 2018 at 12:52 pm

estherP

I am trying to:
Have the same meta data in both translations.

Link to a page where the issue can be seen:

As you can see, this oportunity has investors:
hidden link

And it's version in English doesn't.
hidden link

I expected to see:

Instead, I got:
It's like if the match between languages isn't done, since the oportunities should have the same data (investors, amount...)
Why is this happening?

Thanks

September 24, 2018 at 3:56 pm #2761196

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

If I understand correctly, the custom post type is not displaying in your secondary language. Is this correct? If so, have you translated the post to the second language? Please go to WPML -> Settings and in custom post types section, make sure that the post type is set to translate.

Also, please try increasing the WP Memory Limit. You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it above the line /* That's all, stop editing! Happy blogging. */

September 27, 2018 at 8:52 am #2769833

estherP

Hello,

What I'm saying is this:
For example, you can see 2 opportunities LLEIALTAT 4 listed in the homepage.
First of all:
The opportunity should be listed only once, since in the admin area there is 1 LLEIALTAT 4 in spanish and 1 in english (however the system prints both original and translation)
Secondly:
The funds raised in spanish and english should be the same, as there is only 1 LLEIALTAT. However as you can see, one has been funded with 32 investors and the english version has 0 investors.

I hope I explained it better.

Thanks

September 27, 2018 at 3:02 pm #2770997

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please update the credentials that you previously provided, as they are not allowing me to login.

The reason the opportunities do not have matching data is because a translation is a separate post than the original.How are these funds and investors added to the opportunities? It seems that you will need to set funds/investors to "copy" if you want them to be the same for both the original post and the translated post. You can go to WPML -> Settings and look for these fields and set them to copy.

As to why both languages are showing, how are you displaying this content on the homepage? Are you using a page builder, or is it part of your theme options, etc? Will you be translating the opportunities? Because if you are not, it may benefit you to set Opportunities post type to Translate /Fallback to default. This setting can also be found on WPML -> Settings.

September 27, 2018 at 6:16 pm #2771536

estherP

Try using email:
wpml@crowdsers.com with the password i gave you.

I am uploading a screenshot of the settings.
According to your questions:

1. Investors register in the website, select an opportunity and they fund it. This is the way opportunities get funded.

2. Yes, I am in need of translating the opportunities, but not some of it's meta data.

In case we set these fields to copy, will the effects take place in the opportunities that have been already translated? We've translated many opportunities already.

September 27, 2018 at 6:29 pm #2771583

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Okay, if you will be translating part of the opportunities then Duplicate won't work, since that copies all content to the second language. So the solution for you will be to copy investors and funds to the second language. In order to copy for ones that were previously translated, once you set the fields to copy, you should just be able to edit the original post and then update the translated post and the fields set to copy should then show the translations.