This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bruno 3 weeks, 2 days ago.

Assigned support staff: Bruno.

Author Posts
September 19, 2019 at 3:17 pm

jonathanF-3

I am trying to translate the "Product" Slug in woocommerce.

So far, we've enabled translation on slug in the settings
We've translated the slug : hidden link
We've tried to disable WooCommerce multilingual, save permalink, translate the slug then re-enable the plugin -> Not working
We've also tried to change theme -> Not working

On frontend, the slug stay the same in both language (we need it to be "Product" in english and "Produit" in french)

We've also noticed a double slash in the permalink settings (weird) : hidden link

September 21, 2019 at 5:14 am #4615403

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. When I try to access your site, this error message appears: ERREUR : ce mot de passe ne correspond pas à l’identifiant Dev. Mot de passe oublié ?

I'm not sure, but it seems that within Settings> General the "Home URL" is using the locale. If so, that would be incorrect.

Could you please verify the username and password again so that I can verify your site? Also, after logging in, what steps should I take to see the problem? Your next message will be private.

Thank you.

September 24, 2019 at 12:24 pm
September 24, 2019 at 1:42 pm #4632073

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. Now when I try to access your site an http-auth screen is displayed. I will attach a picture for you to see. I tried using the same WordPress credentials, but it didn't work.

Could you please check again?

Thank you.

September 24, 2019 at 8:55 pm
September 25, 2019 at 1:45 am #4634653

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. I fixed the problem by following the steps below:

- Click on the WPML > Settings > Slug translations
- Check the "Translate custom post and taxonomy base slugs (via WPML String Translation)."
- Click on the Save button
- Scroll down and look at the "Post Types Translation"
- Note that the slug is translated to custom type products.
-- hidden link
-- hidden link

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.