This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by Lauren 4 months, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
May 23, 2019 at 6:51 pm #3878811

priiduT

Didn't got the right help with Laura

May 23, 2019 at 7:13 pm #3878987

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi there, after reviewing the thread that you previously have worked on with Laura, it seems as though the projects are not linked as translations but rather that the projects have been independently created in the secondary languages.

In order to delete the projects that are showing up in your secondary language, please click on the "Projects" tab. Then, use the admin language switcher at the top of your dashboard to switch to your secondary language. Here, you should be able to find the project that you do not want to exist and delete the project. Then, be sure to remove it permanently from the trash.

This should resolve the issue. In order to reduce confusion, please either continue with Laura in the original ticket or close that one and we can continue here instead of having duplicate tickets addressing the same issue. Thanks for understanding.

May 23, 2019 at 7:37 pm #3879101

priiduT

I just tried, deleted one of the projects under ENG language. After deletion went to trash bin and deleted project is deleted in all languages rather than only in ENG language.

May 23, 2019 at 7:39 pm #3879107

priiduT

Would it be possible, that translations will be turned on for all the languages and are visible within the list of porjects with flags in front of them?

May 23, 2019 at 7:48 pm #3879237

priiduT

1 more example. If I open this project in the backend - hidden link

And then switch language in the backend to ENG, it shows empty project.

But if I navigate here - hidden link which is corresponding url of the project and change URL directly from addressbar to this ->
hidden link

so I add en in front of /tehtud-tood/ which is portfolio slug

Then i still get the project as its in here - hidden link

SO there is no project under ENG language in backend, there is something else wrong with the WPML conf

May 23, 2019 at 7:52 pm #3879243

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Yes, you can see the translations available once you set the Project type to Translatable. You can manage this setting in WPML -> Settings in the Post Types section. Then you can view the list of projects and click "All Languages" from the language switcher.

If you are deleting a project that has translations, and you do not want to delete the translations, uncheck the option to delete translations when deleting the post in WPML -> Settings.

May 23, 2019 at 7:55 pm #3879245

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

In order to delete and or edit posts in different languages, you must first go to WPML -> Settings and set Projects to Translatable.

Also, in order for me to continue troubleshooting here, please mark your previous ticket as resolved so that there are not multiple supporters working on this. That can cause confusion and delays in getting the issue resolved.

May 24, 2019 at 7:06 pm #3887229

priiduT

Please answer to my last post.

May 24, 2019 at 9:10 pm #3887637

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please be sure to make a full backup of your site and database.

Then, go to WPML -> Support -> Troubleshooting.

Look for 'Clean up' and click the following:
- Synchronize posts taxonomies
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix Terms count
- Fix post assignment for translations

Then check to see if the /en/ URL still loads. If it is still loading, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyNineteen. With these settings, is the issue resolved?

If you don't have a testing environment available and cannot test this on your live site, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to set up your site locally and run these tests for you.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply. I will also need the username and password of a user that was created before the duplicator package was created.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will enable the next reply to be private so only you and I have access to it. Thanks!

May 31, 2019 at 5:35 pm #3932453

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I was able to extract the files from the Duplicator snapshot, but not the database. Do you mind if I log in to your site and grab a download of the database using the Duplicator plugin?

June 2, 2019 at 7:24 pm #3938161

priiduT

No, Do what needs to be done:)

June 3, 2019 at 5:03 pm #3944731

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I was able to set up a copy of our site locally and could not produce the issue. I have attached a screenshot and when I add /en/ to the URL, it redirects to the URL without the /en/. So perhaps it is a caching issue on your live site? Can you ask your hosting provider to check the server logs to see if there could be anything showing up there? And maybe ask them if server side caching is enabled? Here is a link where you can view the screencast: hidden link