Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by Marcel 1 month, 1 week ago.

Assigned support staff: Marcel.

Author Posts
January 15, 2021 at 12:18 pm

mohamedO-5

Custom post type is fetched in all languages in any language version of my website while i set it to be translatable

January 15, 2021 at 1:02 pm
January 15, 2021 at 4:03 pm #7855053

mohamedO-5

I think i have fixed the problem by setting supress_filters to false but i don't understand why it wouldn't work if set to true

January 18, 2021 at 11:01 am #7867925

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hi,

my name is Marcel and I take over your ticket.

I think i have fixed the problem by setting supress_filters to false but i don't understand why it wouldn't work if set to true

If you have ['suppress_filters'] = true it will disable the WPML filters. For this, you need to go with false. More information about this you can find here: https://wpml.org/forums/topic/get_posts-by-language-and-suppress_filters-false-issue/

Best Regards
Marcel