This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by sarahT-6 3 months ago.

Assigned support staff: Bruno.

Author Posts
July 18, 2019 at 5:16 pm #4241383

sarahT-6

The problem is on this page: hidden link

I made a custom loop but both languages show and one of them is in spanish which I havent even translated it to spanish.

On the french side, none of the custom taxonomies are showing.

July 18, 2019 at 9:18 pm #4242419

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Is this custom loop returning data from posts? Or are you using custom post type?

Please, what is the version of WPML and WP are you using? I would like to know more about your installation. Can you please provide your WPML Debug information in the debug field below? http://wpml.org/faq/provide-debug-information-faster-support/

Thank you.

July 19, 2019 at 1:51 pm #4246851

sarahT-6

I am using Elementor and a grid builder plugin but there is a page where I can't translate placeholders and other support staff isn't being helpful at all so I decided to make a custom loop.

This is the original page I made and wpml support staff can't seem to figure out how to translate this place holders in the dropdowns: hidden link

versions:
wp: 5.2.2
wpml: 4.2.7.1

The code I made myself, I only included some of it to show you what I did.
The code below shows on this page: hidden link
you can see both languages and even spanish is on this page (I never translated anything to spanish). The loop is a custom post type with custom taxonomies.

$args = array(  
           'post_type' => 'resources',
           'post_status' => 'publish',
           'posts_per_page' => -1,
           'orderby' => 'date',
           'order' => 'ASC',
		   'suppress_filters' => 0
       );

       $loop = new WP_Query( $args );


while ( $loop->have_posts() ) : $loop->the_post();
       $terms = get_the_terms( $post->ID , 'publication_type' );
    ?>
       <div class="element-item <?php  echo $term->slug; ?>">
       
            <h2> <?php  echo the_title(); ?></h2>
           <p><?php  echo the_excerpt(); ?></p>
		   <p><?php  	   		
			   

			foreach ( $terms as $term ) {

				echo $term->name;

			}

			   ?></p>
       </div> 
       <?php 
       endwhile;

       wp_reset_postdata();

July 19, 2019 at 2:46 pm #4247049

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. Looking at the debug information I looked that you are using the fallback feature. Please, could you disable this option to see how the posts will be displayed? To do this, follow the steps below:

- Click on the WPML > Settings > Post Types Translation
- On the "resources" post type, select the "Translatable - only show translated items" options
- Click on the Save button

Following these steps, does the problem persist or are the posts displayed as expected?

Thank you.

July 19, 2019 at 5:33 pm #4247697

sarahT-6

My issue is resolved now. Thank you!