Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Diego Pereira 8 months, 1 week ago.

Assigned support staff: Diego Pereira.

Author Posts
March 26, 2019 at 10:47 am #3461575

Jordi Romeu

I have a website in Spanish with a Custom Post Type created with the plugin CPT UI. This custom post type is for products and it has the slug 'productos' in Spanish. Now I'm translating this website to Catalan.

I have configured WPML. In WPML > Settings > Custom post type translation, in the 'productos' custom post type, i've selected the option to make them translatable. Then I configured the slug 'productes' for Catalan.

I am able to translate the posts in the Custom Posts type. But when editing the catalan version, it shows me an incorrect URL: hidden link. Clicking it, I get a 404 error. It has to be hidden link.

I tried to go to WP permalinks option and save it to flush slugs. But it doesn't work.

What I'm missing or doing wrong?

Please, healp!

March 26, 2019 at 1:24 pm #3462869

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @jordi Romeu, welcome to the WPML support Forum!

Please go to WPML > String Translation, search for the "productos" slug. Then translate it to all languages and re-save your permalink structure on Settings > Permalinks.

The issue persist after these steps?

All the best,
Diego

March 26, 2019 at 1:24 pm #3462873

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

IMPORTANT: Please backup your site first before making any change, this is important for security reasons.

March 26, 2019 at 2:57 pm #3463791

Jordi Romeu

Hi Diego.

I've done what you said. When I went to WPML > String Translation, the string was correctly translated to Catalan. I saved it and then I went to Settings > Permalink and saved it.

But the links are not working.

Thx.

Jordi

March 27, 2019 at 1:34 pm #3471495

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I sent some instructions to replicate the website through a private message (previous answer).

Please let me know if it worked for you. If so, please send us clear instructions on how to see/reproduce the issue.

Kind regards,
Diego

March 27, 2019 at 10:22 pm #3475997

Jordi Romeu

Hi Diego,

Website is replicated. You can access with this data:

hidden link
[content removed]

Thanks.

Jordi

March 28, 2019 at 6:38 pm #3484979

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks, It seems that the issue was caused by a conflict with the "WP Better Permalinks" plugin, which is not listed as comaptible with WPML: https://wpml.org/documentation/plugins-compatibility

I solved the issue using the steps below:
- Go to Plugins > All plugins
- Disable the "WP Better Permalinks" plugin
- Go to Settings > Permalinks and re-save your permalink structure
- Go to "Productos > Todos los productos" and translate a product
- Check if both URL's are correct.

It worked on the test site, you can check through these links:
- hidden link
- hidden link

Please let me know if it worked for you.

Kind regards,
Diego