This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by antartika-di-magnabosco-andreaA 5 days, 22 hours ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 15, 2019 at 2:28 pm #4574863

antartika-di-magnabosco-andreaA

I am trying to: tranlsate a custom post type. I used a toolkit plugin to create CPT and a custom taxonomy

Link to a page where the issue can be seen:
I'll let you know this info privately

I expected to see:
I would like to see the page New Molds transleted

Instead, I got: Page is not found

I'read every forum suggestion, I set everythin like documentations indicates, but still no luck.
Everything is up-to-date.

Italian language is the default one, English is the second one. CPT is called Novita () and has a custom slug and so does the english one. There is also a custom taxonomy called Tipologie.
I also added
define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );
in wp-config.php in case you'll need it.

Thank you

September 16, 2019 at 9:36 am #4577951

antartika-di-magnabosco-andreaA

The plugin that I used to create a custom post type is Toolset (not toolkit).

September 16, 2019 at 11:47 am #4579871

antartika-di-magnabosco-andreaA

I tried a few things. I followed this thread: https://wpml.org/forums/topic/original-slug-url-gives-404-toolset-wpml/ and discovered that everything works correctly if I do not rewrite slug of CPT and taxonomy.
But in this way I have ugly URLs.
As soon as I set that slugs should be rewrited with custom slugs, translated archive page gives me an error 404. I wold still appreciate some help. Thanks

September 16, 2019 at 5:07 pm #4582813

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

September 17, 2019 at 7:05 am #4585909

antartika-di-magnabosco-andreaA

I don't see the wp-admin/FTP fields. Could you enable the private box with wp-admin/FTP fields. Thank you

September 18, 2019 at 3:09 am #4592049

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and sorry for the bit of waiting here. The private reply fields are enabled again. Please, let me know if you need any other detail and clarification, have a nice day.

September 19, 2019 at 6:53 pm #4607981

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a look into your WordPress Dashboard and noticed it is something to be further investigated in a separated server environment, for that, please consider:

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Thank you for your collaboration. Have a nice day.

September 21, 2019 at 2:20 pm #4616171

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I will proceed with a detailed investigation and let you know as soon as I have a detailed and accurate answer for you. Thank you for your continued patience and understanding, have a nice day.

September 23, 2019 at 8:52 pm #4626643

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and your patience while waited for a reply. I tested it using the provided duplicator package and could confirm the issue, also I noticed the issue happens even in clean test install which seems to be a bug from our side, I forward your ticket to our second level support for further analysis, I will be back here as soon as I have some more details for you. For now I recommend the following:

1 - Instead of using the 'Use a custom URL format' change to the 'Use the normal WordPress URL logic' option from your WordPress Dashboard > Toolset > Post Types > Options settings.

2 - Translate your slug from your WordPress Dashboard > WPML > Settings > Post types translation settings.

This workaround will work for you, as soon as we have some more details on how to get the translated 'Use a custom URL format' working properly.

Thank you for your continued patience and understanding, have a nice day.

September 25, 2019 at 5:33 pm #4641483

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your patience while waited for a solution. After another detailed look and some local tests I noticed the cause of this issue was a known conflict now fixed between Page Builder by SiteOrigin and WPML addons.

In order to fix that, please, update your WPML Multilingual CMS, WPML String Translation and WPML Translation Management plugins to its latest versions, you find all the most recent versions in your wpml.org account. If you still don't see any admin notice regarding the updates, please try the following to make a manual update.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

1 - In your wpm.org account download the most recent versions of the mentioned plugins.

2 - In your WordPress Dashboard > Plugins deactivate the mentioned plugins and delete them (your data are kept safe in the database even deleting them).

3 - Upload the donwloaded plugin zip folders and activate them.

Please, let me know if it works for you. Have a nice day.

September 27, 2019 at 8:28 am #4652259

antartika-di-magnabosco-andreaA

Thank you very much, I'll let you know how it goes :-).

September 27, 2019 at 2:12 pm #4654843

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Please, let me know the results when you are done, have a nice day.

October 8, 2019 at 9:07 am #4713445

antartika-di-magnabosco-andreaA

Hi Marcos
I updated WPML and now slug rewrite for CPT works correctly and also the translation of the custom slug was done without any problem using WPML string transaltion.

I still heave difficulties with translating custom slug for a custom taxonomy.
I used string translation to translate a custom slug for CPT, therefore I wanted to the same thing for the taxonomy slug, but there is noting to translate. I'm searching the string, that should be my custom slug, but I can only see the default slug that I assigned to the custom taxonomy.
Thank you