Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 3 voices.

Last updated by Harshad 6 years, 11 months ago.

Assigned support staff: Harshad.

Author Posts
September 30, 2013 at 1:27 pm #270678

daniel

Hello
i had a lot of problems with wpml and the sommerce theme. As you could'nt find where the problem was comming from I finally decided to move on and to change my theme, so now i use twenty twelve, that i customized a litlle bit.

Still now i have this problem i also already had before :

"Translate custom posts slugs option" is beeing checked "On" all the time alone !!
I don't understand why, and it's causing problem to go from one language to the other !

Did you hear about this problem already ??

I think my plug ins are all updated

thanks for your help

September 30, 2013 at 1:31 pm #270682

daniel

for infos i did uptated woocommerce multilingual with version 2.9.12.-b5 but it still write Version 2.9.2 in the plug in list.

September 30, 2013 at 3:40 pm #270753

Bruno

Dear Daniel,

You should keep the default ( empty ) permalink to WooCommerce ( Settings > Permalinks ). I attached a picture for you to see.

This should be translated by clicking on the WPML > WooCommerce Multilingual > Products, Product Categories and Product Tags.

Please let me know if this solves the problem.

Thank you.

September 30, 2013 at 3:49 pm #270765

daniel

Soory i wasn't clear
i don't want to translate slugs and this option is always checked !

and i tried to do what you said but nothing is working ! going from one language to the other gives me a 404 page !!
sorry but i begin to be bored with all this, i just haves bugs and bugs with wpml !!

September 30, 2013 at 9:01 pm #270880

Bruno

Dear Daniel,

I will assign this topic to Harshad, who is our senior developer.

Soon he will get in touch.

Thank you.

September 30, 2013 at 9:39 pm #270891

daniel

Hello i reinstalled from zero and the problem is gone for the moment.

But now I have this issue :
http://wpml.org/forums/topic/disappointed-woocommerce-message-doesnt-translate/

Hope it's easy to fix..
...

October 1, 2013 at 6:18 am #270939

Harshad

Dear Daniel,

Sorry for inconvenience, I gave a try adding a product to cart, I see the translated message
""Funky Party" a été ajouté à votre panier" at myside.

Is it not working for you, let me know If I am missing something.

The topic ‘[Closed] Custom posts slug translation always put on !!’ is closed to new replies.