This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Carlos Rojas 4 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 4, 2019 at 11:04 am #3950739

sashaP-2

When using the advanced search in my theme, I initially see the results of the query as expected, but when I type in a subsequent search word (in my case, it is a location/city name), I see a duplication of taxonomies and categories displayed on the listing card (please see image).

I expected to see: taxonomies and categories displayed as per languages selected and without duplication

Instead, I got: taxonomy and category terms duplicating in results.

June 4, 2019 at 12:07 pm #3951309

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you very much for contacting WPML support.

This seems to be a theme issue, have you tested it with the parent theme and check if the issue persists? Also, have you contacted the theme's authors?

I recommend you to visit this link where you will find theme's official documentation on how to translate it using WPML: hidden link

Regards,
Carlos

June 4, 2019 at 12:44 pm #3951775

sashaP-2

Hi Carlos,

I have contacted theme authors, they told me to contact WPML as this is WPML issue which is out of their control.
They said they have seen this happening with their blog posts also, where category terms are duplicating.
I am assuming there may be some incompatibility causing this.

All categories and taxonomies have been translated according to the help files you directed me to.

June 4, 2019 at 1:33 pm #3951993

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your message.

To isolate the cause of this issue I have created a test site with a fresh new WordPress install and the WPML plugins. I kindly ask you to install the theme and try to reproduce the issue.

You can access the test site by following this link: hidden link

Where you able to reproduce the issue?
Regards,
Carlos

June 5, 2019 at 8:06 am #3957837

sashaP-2

Hi Carlos,

I was unable to upload the theme at the test site - it keeps giving me a service error, unfortunately.

I can confirm, however, that this issue only happens when I duplicate my property listings in wpml to other languages.
I'm not sure if perhaps there are some settings which are creating these extra duplications?

June 5, 2019 at 2:15 pm #3961285

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

June 11, 2019 at 1:23 pm #3995671

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

I wasn't able to reproduce the issue (see attached image). I suspect that the cause of this issue might be related to an outdated cache memory.

Regards,
Carlos

June 11, 2019 at 10:46 pm #3998749

sashaP-2

Carlos - did you follow my instructions?
The way to replicate it, as I said, is to click on "Search" WITHOUT typing in any search criteria, and THEN once you're on the search results page, type in a city name, such as "Mostar", after which the results will filter and you will see the duplication.
You will NOT see this type of behaviour if you simply type in a search criteria at the very start on the homepage and click on "search".
I will make a video for you if that helps - please enable private messaging for me.

June 11, 2019 at 10:47 pm #3998751

sashaP-2

Also please refrain from posting screenshots with our site publicly visible to all! (please remove your screenshot). This is bad practice.

June 11, 2019 at 11:11 pm #3998831

sashaP-2

Furthermore Carlos, I noticed that you created/modified a booking record, as well as created and deleted an invoice. Can you provide validation as to why you needed to create and delete these records?

Please also remove the screenshot from your last post, any future screenshots should be sent as an attachment via email.

June 12, 2019 at 2:11 am #3999079

sashaP-2

Carlos,

Also noticed that you installed a plugin to replicate our site without our permission. Can you pease explain why you did this as now you've opened us up to a huge security risk.

This is a legal matter.

June 12, 2019 at 7:16 am #4001003

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

1.- Yes I followed your instructions step by step and wasn't able to reproduce the issue. (I tried again but the account was disable).

2.- I'm sorry for the public screenshot but that's the way this forum works by default, however I have deleted the screenshot as you requested.

3.- Yes, I installed a plugin and created a temporary backup of the site just in case something went wrong. This is a normal practice that help us to restore a site if necessary.

You can read in the message I requested access to the site that I mentioned the possibility of creating a copy: " In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site."

Also, you can read more about our policy in this link: https://wpml.org/documentation/privacy-policy-and-gdpr-compliance/#data-shared-with-our-support

4.- Could you restore the credentials shared so I can double check if I'm able to reproduce the issue this time with the 'Mostar' search criteria?

Regards,
Carlos

June 12, 2019 at 7:21 am #4001039

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I forgot to answer this question: Can you provide validation as to why you needed to create and delete these records?

I created /deleted a booking/invoice just as a part of a set of steps I followed trying to spot any other duplicated information as I wasn't able to reproduce the original issue.

As no issue appeared I removed the booking/invoice created.

Regards,
Carlos