We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by sarahT-6 3 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 24, 2019 at 8:36 pm #4277497

sarahT-6

I had my site setup and noticed on the translated side the my taxonomies weren't translated. I translated them and now they are gone. This happened to me before but as quick walk around I recreated that particular taxonomy. I don't want to do this every time please fix this bug.

This is the original page, the taxonomies are in the dropdown: hidden link

Broken taxonomies on the dropdown here: hidden link

July 25, 2019 at 12:39 am #4278043

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 25, 2019 at 2:18 pm #4284125

sarahT-6

The custom taxonomies are still there actually its just when I made a loop from get_terms, they stopped showing on the french side. This happened to me before. Is there something weird with that function and translation?

Here is an example. This works on the english page but not french. Other terms this works on the french, so why only after i translated these terms they stopped?

  $contact_type= get_terms('contact_type');
     foreach ( $contact_type as $Cterms ) {
       echo '<option value=".'.$Cterms->slug.'">'.$Cterms->name.'</option>';
     }

I only really need to loop through them for a select box.

July 25, 2019 at 2:41 pm #4284351

sarahT-6

I have solved my issue. For some reason after I translated I had to format my code like this

$terms = get_terms( array(
    'taxonomy' => 'post_tag',
    'hide_empty' => false,
) );