Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 31 replies, has 3 voices.

Last updated by julianZ-4 2 years, 7 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
September 29, 2018 at 6:14 am #2775396

julianZ-4

I have an error in Google Search Console saying that I have a lot of duplicate content (see screenshot).

The problem seems to be with the translation of a custom taxonomy.

You can find the same content on:
hidden link
hidden link

And all other custom taxonomy translations.

When you go look at the html source code, you can see the correct hreflang-tags as well as the correct canonical tags. Problem is: hreflang-tag and canonical tags are not compatible.

That would be no problem, if Google would not find the second (nonsense) URL in this case: hidden link (It's still the main language, but in the subfolder for the italian translation). This URL is not referenced in the sitemap and I could not find it on the page anywhere.

How can I disable that the custom taxonomies for other languages are displayed in the same subfolder?

Screenshot_3.png
September 29, 2018 at 8:02 am #2775454

julianZ-4

You won't be able to test it on my site / links I provided. I did a htaccess rewrite to all URLs Google found in the Search Console

October 1, 2018 at 2:45 pm #2778546

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

October 8, 2018 at 10:07 am #2795487

julianZ-4

Hello Bigul

Thanks for your response. Please find attached the debug info.

If possible I don't want to give admin access, because last time I gave admin access to one of your support people, they broke my live site so I had to fix it in the evening and lost many customers.

You can find an example here (I will leave it unresolved): hidden link

It's the exact same content as on hidden link

I don't know why it's generated nor where it's linked from so Google can find it.. But unfortunately, it's there.

If it's not possible to remove this second version with the duplicate content, it should at least be on noindex. It's a very annoying bug after the Google Panda update.

Best regards

Julian

October 9, 2018 at 3:02 pm #2800668

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Julian,

Thank you for the details. I have consulted about this with our team. Sorry, we have to debug further to track the issue.

Please try the following troubleshooting steps after a full site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page
2) Click on Troubleshooting link (blue link in the middle of the page)
3) In Troubleshooting page, please click on the following options of *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

If you are still having the issues, please consider a staging site so it will not affect your live site. Please let me know your feedback.

--
Thanks!

Bigul

October 9, 2018 at 3:45 pm #2800919

julianZ-4

That did not help, unfortunately.

To me it does seem like a bug within WPML.. maybe because it's used together with rehub theme.

Can you please mark my next answer private so I can give you the details to a testsite`?

October 9, 2018 at 4:47 pm #2801186

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Julian,

Thank you for the feedback. I am enabling the private option for the next reply. Please check.

Also please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

October 10, 2018 at 1:52 pm #2804529

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Julian,

Thank you for the login information. When I check for the Posts or Terms in the frontend it is showing 404 error in the test site. Please check the attached images. Hope the test site is the latest clone copy of the live site.

So I am not able to replicate the issue on the test site. Please check and let me know your feedback.

--
Thanks!

Bigul

2018-10-10_1921.png
2018-10-10_1901.png
October 10, 2018 at 2:03 pm #2804644

julianZ-4

Hi Bigul

You're right, the test site doesn't seem to be working.

What exactly do you want to test? If you just want to get a duplicator copy, you can access my live site for this purpose.. If so, please mark my next answer as private so I can provide you with the details.

Best regards

Julian

October 10, 2018 at 4:50 pm #2805261

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Julian,

Thank you for the updates. We would like to go through it in a minimal setup for further checking. I am enabling the private option for the next reply. Please check and share me the credentials of your live site. I will only make a Duplicator copy.

--
Thanks!

Bigul

October 16, 2018 at 7:09 am #2819871

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Julian,

Thank you for the login information. I made a Duplicator copy of the site now. Will check it further and get back to you soon. Please wait.

--
Thanks!

Bigul

October 16, 2018 at 7:15 am #2819903

julianZ-4

Okay thanks. Were you able to reproduce the bug, then?

October 17, 2018 at 8:21 am #2823747

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Julian,

I have tried to reproduce the issue in my local copy with few terms. In my tests, the issue is existing for *Tchibo* and *Tally Weijl* terms. But the Yoast Sitemap is not showing these wrong URLs, hidden link & hidden link. The issue is existing when all other plugins are inactive.

Therefore I will cross check it with our second tier team and get back to you soon. Please wait.

I have one more request. Please share me the latest version of *Rehub theme*. They have released a new version few days ago. I am enabling the private option for the next reply. You can share it via Google Drive or Dropbox.

--
Thanks!

Bigul

October 19, 2018 at 10:59 am #2831690

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Julian,

Thank you for the latest theme file and feedback. The issue is existing for me now. So I have forwarded the details to our second tier team for the expert opinion. We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

October 19, 2018 at 4:55 pm #2832743

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Julian,

For your kind updates, the taxonomy term from one language is accessible by the slug in any other language. Because the taxonomy term slug(*tally-weijl-fr* or *chibo-fr*) is already existing in the Database.

Therefore as a workaround please use a plugin like *Redirection* and redirect URLs having the issue to the proper language. After that reindex your site and check the issue is existing or not.

Please try it and let me know your feedback.

--
Thanks!

Bigul