This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.56 hours from now. Thank you for your understanding.

This topic contains 9 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 1 month, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 30, 2019 at 10:43 am #4486523

elisabethS-9

I am trying to: translate a product page containing a custom text field

Link to a page where the issue can be seen: hidden link

I expected to see: the same custom text field also in the translated German version

Instead, I got: custom text field in German version is not displayed

August 30, 2019 at 5:45 pm #4488673

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

September 2, 2019 at 11:34 am #4496609

elisabethS-9

Hi Marcos,
I wanted to check if you could access the site and if there are any news? Thanks and best, Elisabeth

September 2, 2019 at 2:18 pm #4497629

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Elisabeth,

Thank you for the updates and sorry for the bit of waiting here. I took a detailed look in your website and noticed the issue happens due your additional custom fields configuration, currently they are all set as 'Don't translate', in order to have their values copied from your default language page to your secondary language pages, you should proceed this way:

1 - In your WordPress Dashboard > WPML > Settings > Custom Fields Translation click the blue link 'Show system fields'.

2 - Using the searchbox of the custom fields translation settings search for the custom fields that starts with '_alg_wc_pif_' and set them accordingly.

2.1 - you should set it as 'Copy' for those custom fields you need their value to be the same in your translated product, for example the '_alg_wc_pif_enabled_local_1' to make the 'Enable/Disable' checkbox of your additional custom fields also enabled in your translated product.

2.2 - You should set the '_alg_wc_pif_title_local_1' as 'Translate' in order to translate it in your secondary language product post.

For all the other fields you should follow the same concept. See: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

3 - Now you should click to edit your product in the default language and click the update button in order to make your custom fields translation settings to take effect.

Note: You can also edit your translated products using the default WordPress Dashboard post/page editor and manually update their custom fields.

Please, let me know if you need any additional assistance and clarifications, have a nice day.

September 3, 2019 at 3:07 am #4500721

elisabethS-9

Thank you very much, Marcos, for your support. It worked out. I just have one more minor question: there is some text next to that custom text field saying "Please enter the letters...". I have tried to translate it in the product translation and I also searched the strings but somehow I'm unable to translate it. Have a nice day and thanks! Elisabeth

September 3, 2019 at 5:10 pm #4506519

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I tried to access your website to give a further look in your latest request but it seems you moved it to another host/domain. In any case you should be able to edit this custom field label in the secondary language of your product. Here is how:

1 - Click to edit your product in the default language then change to your secondary language using the language switcher at the top admin bar.

2 - Now look for the custom field label and change it to suit your needs, save your product post and you should be done.

Please, let me know if these instructions works for you, have a nice day.

September 4, 2019 at 1:20 am #4507569

elisabethS-9

Hi Marcos,

Thank you for your reply and your support.

Yes, sorry, I moved the page yesterday to hidden link. The admin details still work. Do you need a new FTP access?

I tried to change it already via the product page, I went into the product, switched to German and then added the German text but when I click "update", the changes are not saved and it goes back to English. I have attached a screenshot of the input field.

Have a nice day and best regards,
Elisabeth

September 5, 2019 at 1:51 am #4514473

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. It happens because your custom field '_alg_wc_pif_title_local_1' was set as 'copy' in your WordPress Dashboard > WPML > Settings >Custom Fields Translation when doing so you translated custom fields values will be kept in synchronization with your default language custom field value, it means it will persist with the same value of your default language whenever you save your default language product. I set it as 'translate' this way you are able to translate them individually.

See: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

Please, let me know if you see your changes saved now. Have a nice day.

September 5, 2019 at 2:20 am #4514645

elisabethS-9

Perfect, it works now. Thanks a lot for your support with this issue. Have a nice day and best, Elisabeth

September 5, 2019 at 2:10 pm #4519971

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Elisabeth,

I am glad it works now. Don't hesitate in opening a new ticket for any issue you might have in the future, have a nice day.

Kind regards,
Marcos.