This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by dusanV-2 2 months, 2 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 29, 2019 at 3:44 am #4296747

dusanV-2

I want to create a custom XML where an ID is defined. Then change this ID in the Translation Editor. Unfortunately, I won't see the ID for the translation.

This is the code.
[wpforms id="244" title="false" description="false"]

I use this XML.
<wpml-config>
<shortcodes>
<shortcode>
<tag>wpforms</tag>
<attributes>
<attribute>id</attribute>
</attributes>
</shortcode>
</shortcodes>
</wpml-config>

July 29, 2019 at 6:13 am #4297121

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue

I'm afraid numerical values will not appear for translation in WPML translation editor, Rather they are copied to the translation by default.

Could you please let me know the purpose of changing the form id so that I can suggest any other alternative way if available.

Kind regards
Raja

July 29, 2019 at 6:20 am #4297137

dusanV-2

I use WPform, where I have a different form for each language. WPML translation alone is not possible. So I try another solution to use the Translation Editor.

July 29, 2019 at 12:20 pm #4299539

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Instead of using the translation editor use the manual translation method (using WordPress default editor) which will allow you to replace the shortcode with another Wpform shortcode.

To switch to the manual translation mode, open a page that you want to translate. In the Language box, turn off WPML’s Translation Editor switch found in the Translate this Document section. please refer to the attached screenshot

Make sure you have marked the translation as 100% complete in WPML translation editor before switching to manual translation.

Please note, Manual translation doesn't copy the layout of the page and the design you might need to redo the page layout in the translation.

I hope this helps you better.

Kind regards
Raja

July 30, 2019 at 4:12 am #4304685

dusanV-2

My issue is resolved now. Thank you!