This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I would like the admin dashboard to show in just one language instead of changing when the language switcher is changed.

Solution: Go to Users -> Your Profile and deselect "Set admin language as editing language." and set the Language to English (see attached screenshot).

This topic contains 9 replies, has 3 voices.

Last updated by todorS 1 year, 11 months ago.

Assigned support staff: Lauren.

Author Posts
October 27, 2017 at 8:24 am #1413787

bilginK

Tell us what you are trying to do?
I will have 4 languages on my web site. Turkish - English - Hungarian and Dutch. The default language will be Turkish. I was trying to figure out how WPML works. For Turkish pages, wordpress dashboard and Divi (theme I use) became Turkish. For dutch, dashboard and Divi became dutch. I don't want to use nor wordpress neither Divi in Turkish, Dutch or what else. It is for me to impossible to work on them. Dashboard and Divi theme must stay in English. Is there any settings for it?

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

October 27, 2017 at 7:19 pm #1414499

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

You can go to Users -> Your Profile and deselect "Set admin language as editing language." and set the Language to English (see attached screenshot).

In addition, if you are not planning to use .mo/.po files to translate your site content, you can go to WPML -> Theme and plugin localization and select "Translate the theme and plugins using WPML's String Translation only (don't load .mo files)" and this will prevent the .mo files from loading and showing the translations.

Please let me know if you need any further assistance and I will be happy to help.

October 31, 2017 at 11:03 am #1416638

bilginK

Hi,

I did it. From my profile, I set admin language is English, also dont load .mo files option is selected. I am sending screenshots; for example if I choose macedonian pages, dashboard (and also divi builder) becomes macedonian. For every language, admin panel changes. It is not normal, is it? It is impossible for me to edit any pages in dutch or macedonian.

October 31, 2017 at 2:41 pm #1416940

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

November 1, 2017 at 2:00 pm #1417906

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

The WordPress credentials provided are not allowing me to access your site. I get the error message:

ERROR: Incorrect username or password.

Can you please double check and update as needed? I have marked the next reply as private. Thanks!

November 1, 2017 at 3:39 pm #1418062

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks, the credentials worked this time. There is a checkbox on the user profile page for " Set admin language as editing language." This checkbox was selected, so any time you changed the language switcher, the editing language was changing to. Deselecting this checkbox resolves the issue.

Please let me know if you need any further assistance and I will be happy to help.

November 1, 2017 at 3:45 pm #1418074

bilginK

Ohhhh! I red "select" in your first message, not "deselect"... just a mistake! Sorry for all this :))

November 1, 2017 at 3:54 pm #1418108

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Great, I'm glad we were able to resolve this for you 🙂 Have a great day.

May 24, 2019 at 1:33 pm #3885313

todorS

Hello. I am having the same problem but when I go to WPML -> Theme and plugin localization the first two options and the one that I have to choose according to the fix, namely "Translate the theme and plugins using WPML's String Translation only (don't load .mo files)" is not available. Instead the option "Don't use String Translation to translate themes and plugins" is chosen by default and the other two are inactive. Any suggestions on how to fix this? Thanks in advance.

May 24, 2019 at 1:43 pm #3885371

todorS

I fixed it. No problem.