This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by albertoG-50 1 week, 2 days ago.

Assigned support staff: Diego Pereira.

Author Posts
October 10, 2019 at 12:49 pm #4730457

albertoG-50

In my blogpage I have the "AddToAny Share Buttons" plugin to share posts.

The thing is that after I installed WPML, the content moved to the spanish directorie hidden link and the count of times that the post has been shared is lost.

Is there any way to get back the sharings or maybe that the predetermined language (Spanish) doesn't need a directory?

Thank you

October 10, 2019 at 6:10 pm #4733425

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello, welcome to the WPML support Forum!

It seems that the plugin uses the URL to count the times that the post has been shared. Since the URL has been modified ("/es" has been added) it no longer recognizes the counter. So it's expected.

The only way to remove the "es" directory from the URL is to set Spanish as the default language of the website. You can do this on WPML > languages. Please check these link for more details: -
- https://wpml.org/documentation/getting-started-guide/language-setup/
-https://wpml.org/documentation/getting-started-guide/language-setup/language-url-options/

IMPORTANT: Please backup your site first before making any change, this is important for security reasons.

Please let me know if it worked for you.

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.
NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

All the best,
Diego

October 11, 2019 at 8:36 am #4736465

albertoG-50

Thank you for your help Diego.
I look into the configuration and realized that I had checked the box "Use directory to predetermined language". Once I unchecked it it works perfect.

Thank you!