If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: after importing content from Polylang to WPML, content with zh-tw language code became zh-hans (Semplified Chinese), but I need them in zh-hant (Traditional Chinese)

Solution: 1. Add Traditional Chinese in WPML -> Languages -> Add language (it's already pre-built with WPML so you only need to check the box) 2. go to WPML -> Translation Management 3. Select all your Simplified Chinese content 4. In the box "Translation options" select "Duplicate content" near Traditional Chinese and click "Duplicate" 5. Check everything is duplicated as it should 6. You can now delete all Simplified Chinese content and remove the language if you wish

Relevant Documentation: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/#batch-duplicating

This topic contains 6 replies, has 2 voices.

Last updated by kotaroS 1 year ago.

Assigned support staff: Laura.

Author Posts
October 23, 2018 at 2:29 am

kotaroS

I am trying to migrate from Polylang to WPML by using the migrate-polylang-to-wpml plugin.

So far I've got 2 errors.

1) I can see this message on control panel as below;

"We have detected a problem with some tables in the database. Please contact WPML support to get this fixed.

Array
(
[language] => ja
[context] => admin_texts_ctdb_options_settings
[gettext_context] =>
[domain_name_context_md5] => 0c09a74c47eb7604d1ded3b66e5c6344
[name] => [ctdb_options_settings]redirect_to_page
[value] => 4273
[status] => 0
[translation_priority] => optional
[allow_empty_value] => 1
)"

2) Polylang's default language was Taiwan-Chinese(繁体中文), and the second language was Japanese. After migration, Japanese posts are all seen on /ja/ , but Taiwan-Chinese posts (default URL) are all gone. Also in WordPress control panel (post menu), I can confirm only Japanese posts.

I wish you could help us out of this situation. Thank you for your support.

October 23, 2018 at 3:01 pm #2843118

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

1. Please read the quick summary here: https://wpml.org/forums/topic/wpml-is-telling-me-that-it-has-a-broken-table-that-needs-fixing/
and our errata page here: https://wpml.org/errata/missing-_icl_strings-_icl_string_translations-data-tables/

2. Try going to WPML -> Support -> "troubleshooting" link -> "Set language information" button.
Please backup your site before doing this. You could also try to clear the cache on the same page.

Let me know if this helps you or if you need further assistance.

October 24, 2018 at 1:35 am #2844273

kotaroS

Hi, Laura! Thanks for your support.

So far
1) I try "Add this code to the bottom of the functions.php file in your theme’s root folder," but can't confirm any changes.

2)Most important for us is Taiwan-Chinese(zh-tw) posts are all can't be seen on website.
I tried this step, "Try going to WPML -> Support -> "troubleshooting" link -> "Set language information" button," but still can't see any posts.

Japanese posts(ja) are here.

But Taiwan-Chinese posts(zh-tw) are all gone. Where are they?

These posts are all langauage paired.

So I'm still in stuck. Would you have any other recommends? Thanks!

October 25, 2018 at 11:19 am #2849528

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

I think the issue here is that WPML doesn't have a zh-tw language code. We have zh-hans for Simplified and zh-hant for Traditional Chinese.

So probably your posts are still in the database, just they don't have a language associated.
What you can try is to create a custom language with zh-tw in WPML -> Languages -> Edit Languages and then try to set up the language as I explained in my previous post.
Please see here for more information on how to create a custom language: https://wpml.org/documentation/support/editing-wpmls-languages-table/

If this doesn't work, I'd ask you for a copy of your site so I can further check.

October 27, 2018 at 12:34 am #2854294

kotaroS

Thanks for your help. Yes by WordPress.com's support, I already found those files in "zh-hans" and could be activated and published on my website.

The problem is those files are actually "zh-hant" for Traditional Chinese, but I can't change the code "zh-hans". Because we need to use third party translation service, the code difference would bring some error.

Therefore please let me know how to migrate all files (post, category, etc) in "zh-hans" into "zh-hant" safely.

Thank you so much.

October 29, 2018 at 9:52 am #2857328

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

the best way to do it is to bulk-duplicate them. You can try as follows:

1. Add Traditional Chinese in WPML -> Languages -> Add language (it's already pre-built with WPML so you only need to check the box)
2. go to WPML -> Translation Management
3. Select all your Simplified Chinese content
4. In the box "Translation options" select "Duplicate content" near Traditional Chinese and click "Duplicate" (check our documentation: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/#batch-duplicating)
5. Check everything is duplicated as it should
6. You can now delete all Simplified Chinese content and remove the language if you wish

Let me know if this helps you or if you need further assistance.

October 29, 2018 at 11:50 pm #2859827

kotaroS

My issue is resolved now. Thank you!