This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 28 replies, has 2 voices.

Last updated by Bigul 2 weeks, 4 days ago.

Assigned support staff: Bigul.

Author Posts
May 26, 2020 at 4:48 am #6215267

francescoL-19

Hello,

I'm Francesco from Italy. I'm not very expert of WP.

My website has 50 plug-ins and the database size is 100MB.
The problem is that 52 MB is only WPML!

wp_icl_strings
Uppercase: 0 Rows: 14,913 Size: 10.03MB

wp_icl_translate
Uppercase: 0 Rows: 21,214 Size: 42.02MB

I already pressed all button in the WMPL troubleshooting page, and they helped.
But the DB size still too big!
I think the problem are somewhere in the "String translation" page.
I have the suspect I have too many string but... how can I remove the unnecessary strings?
Or, do you have another idea?

In attachment the database info extracted from the Duplicator plugin.

Thank you! =)

May 26, 2020 at 9:01 pm #6223535

francescoL-19

Hello.. I need help!

May 27, 2020 at 8:06 pm #6232749

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

We have released a new version recently and it has many improvements. So please try the following steps after a full site backup and check is there any difference in the result.

1) Upgrade to the latest version of WPML(4.3.14 series) and WooCommerce Multilingual(4.9.0)
2) Go to WPML>>Support page, click on Troubleshooting link (blue link in the middle of the page)
3) In the Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Cleanup and optimize string tables
- Show custom MO Files Pre-generation dialog box>>Generate .Mo files

May you have to visit Plugins>>Add New>>Commerical tab and click on *Check for updates* button to get the upgrade links. This step will help us refresh the installer caches. Now WPML is releasing as a batch in the first few days of the release. So the upgrade notice will be visible only to a few of the customers. The count will increase each day. It will help us handle the situation easily incase of any bugs in the release.

--
Thanks!

Bigul

May 28, 2020 at 12:57 am #6233889

francescoL-19

Hello,

I don't see yet the new update. I think I need to wait...
But, I have: wp_icl_strings Rows: 14,913 Size: 10.03MB that I would like to remove and I cannot remove them by hand!

How can I do it?

May 28, 2020 at 10:40 am #6238007

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. It requires further checking. Because removing the entries directly from the Database tables will make conflicts in the data relationships.

Therefore please try the following steps after a full site backup and make sure the issue exists or not.

1) Go to Plugins>>Add New and select *Commerical* tab
2) Click on *Check for updates* button. This action will refresh the WPML Installer cache and we will get the upgrade links to the latest version
3) Upgrade to the latest version of WPML(4.3.14 series) and WooCommerce Multilingual(4.9.0)
4) Go to WPML>>Support page, click on Troubleshooting link (blue link in the middle of the page)
5) In the Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Cleanup and optimize string tables
- Show custom MO Files Pre-generation dialog box>>Generate .Mo files

--
Thanks!

Bigul

May 28, 2020 at 3:31 pm #6241087

francescoL-19

HGi,

ok, I did id and, and the wp_icl_translate still huge (42 MB)...
It's so strange because my website is small... It's almost a portfolio website plus a tiny ecommerce with two languages...

May 28, 2020 at 6:41 pm #6243277

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

Also please allows me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

June 1, 2020 at 6:04 am #6263013

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details and Duplicator package. I will debug the issue further and get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

June 2, 2020 at 8:14 pm #6277253

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I am still working on this issue. The *wp_icl_translate* and *wp_icl_strings* tables shows same size in my local copy after the initial troubleshooting steps. Therefore I am consulting about this with our second-tier team for the expert opinion.

We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

June 5, 2020 at 2:03 am #6299725

francescoL-19

Hello Bigul,
that's nice.. So, how is the situation now?

How did you solved the wp_icl_translate problem?

June 5, 2020 at 2:39 pm #6306555

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

We are still troubleshooting the issues. It looks like the *wp_icl_translate* and *wp_icl_strings* tables showing as big because of the following.

1) The size of wp_posts and wp_postmeta tables are 10 and 20 MB. It shows the same after resetting WPML on our local copy. Please check the attached images for more details.

2) There are 15,000+ strings for translation, please visit WPML>>String Translation panel to check it

Therefore we would like to know do you have site backup before installing the WPML on your site.

--
Thanks!

Bigul

June 5, 2020 at 2:49 pm #6306651

francescoL-19

Hi Bigul,

your picture are too small =) . I'm not able to see...
By the way, I installed WMPL at the beginning, because I knew that my website needed to be bi-languages.
So, no, I have no backup of my website without WMPL.
I mean, somewhere I have old backup if you need it (february 2019).
But I'm 99% sure it has WPML installed.
Do you need it?

June 5, 2020 at 3:00 pm #6306763

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. The one with WPML will not be much helpful. As of now, it is a kind of expected result. Because the wp_posts and wp_postmeta tables size.

Please check the attached images now. Sorry for the small ones.

--
Thanks!

Bigul

June 5, 2020 at 3:03 pm #6306873

francescoL-19

So, from what I understood, we cannot do nothing, right?
Is as it is...
Or, can you do something? =)

June 5, 2020 at 4:07 pm #6307279

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I have shared the details with our team and waiting for the expert opinion. But it will be almost normal. Because *wp_icl_translate* table will be keeping the translations data of wp_posts, wp_postmeta, wp_terms etc..

--
Thanks!

Bigul