Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Database table icl_string_pages too big Solution: You can try to reset the wp_icl_string_pages. This table is just a cache table. - Go to WPML -> Support -> Troubleshooting page - Press the "Recreate ST DB cache tables" button Relevant Documentation: Can you look at these topics and try what is suggested there? https://wpml.org/forums/topic/table-wp_icl_string_pages-is-too-big/ https://wpml.org/forums/topic/the-table-wp_icl_string_pages-has-over-350000-records/ https://wpml.org/forums/topic/table-wp_icl_string_pages-does-not-stop-growing/

67% of people find this useful.

This topic contains 7 replies, has 6 voices.

Last updated by Bruno Kos 2 weeks, 2 days ago.

Assigned support staff: Bruno Kos.

Author Posts
February 20, 2019 at 9:23 am

jolienH-2

I am trying to: reduce the size of table icl_string_pages
I searched the forum for solutions, disabled auto register strings for domains, deleted many strings, but database keeps growing. I see there are many others with the same problem, is there a solution to solve this? Please help me out.

February 20, 2019 at 1:55 pm #3222102

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Thank you for contacting WPML support!

Can you look at these topics and try what is suggested there?
https://wpml.org/forums/topic/table-wp_icl_string_pages-is-too-big/
https://wpml.org/forums/topic/the-table-wp_icl_string_pages-has-over-350000-records/
https://wpml.org/forums/topic/table-wp_icl_string_pages-does-not-stop-growing/

You can also find some information on what this table contains and how is it filled up.

You can try to reset the wp_icl_string_pages. This table is just a cache table.
- Go to WPML -> Support -> Troubleshooting page
- Press the "Recreate ST DB cache tables" button

Please make a full backup of your site before trying this or make these changes on a staging/development site!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

February 22, 2019 at 8:21 am #3231289

jolienH-2

My issue is resolved now. Thank you!

May 12, 2019 at 3:03 pm #3793189

mauroM-8

I have the same problem with wpei_icl_string_pages
I have made all!
I have the last version WPML
This table is just a cache table. - Go to WPML -> Support -> Troubleshooting page - Press the "Recreate ST DB cache tables" button.
But nothing the db grow up

October 30, 2019 at 10:33 am #4854643

Waldemar Kawulski

i have this same problem, my table wp_icl_string_pages have: [Uppercase: 0 Rows: 7,199,414 Size: 729.83MB]
i try use instruction to recreate DB but... from this place:
https://wpml.org/forums/topic/table-wp_icl_string_pages-is-too-big/
But i dont see [Recreate ST DB cache tables] option on my page!!

November 22, 2019 at 3:45 pm #4999837

frederickG-2

Same problem but I dont see
But i dont see [Recreate ST DB cache tables] option on my page!!

February 6, 2020 at 10:57 am #5438061

uweH

I guess the "Recreate ST DB cache tables" button is now called "Cleanup and optimize string tables" (which is far more user friendly terminology) - see here: hidden link

I pressed that and the size of the table "xxxxxx_icl_string_pages" went from 625MB down to 0.1KB!!

February 6, 2020 at 10:59 am #5438131

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Yes, and that table will be used no more:
https://wpml.org/changelog/2019/10/wpml-4-3-with-revamped-string-translation/#comment-2690623

Regards,
Bruno Kos