This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 5.84 hours from now. Thank you for your understanding.

This topic contains 12 replies, has 7 voices.

Last updated by ugoL-3 3 years ago.

Assigned support staff: Bobby.

Author Posts
September 22, 2016 at 7:28 am #1093893

joanv-3

Lately I noticed there was an other update to WPML from 3.5.1.1 to 3.5.2. I wanted to check what has changed, but a change log is nowhere to be found.
To be honest I lost my faith a bit in WPML as it seems to be quite unstable; with the last few updates several new problems were introduced, among which the issue with the exploding wp_icl_string_pages table. Therefore I wanted to make a snapshot of the live version to test the update before putting it live, but importing the database fails on the testsite. On closer inspection I noticed the wp_icl_string_pages table is once more growing rapidly, 2.315.437 rows and 87.2MB , so it seems the bug wasn't fixed properly the last update.

So now I'm stuck with a situation where I have a leak in the database due to WPLML, I don't want to update WPML on the live site because I'm afraid it might break the site, especially since I cannot check the changelog to asses if there was anything fixed on this part to justify the risk. But I can't test the update on the testsite either because the import fails due to the same bug.

All in all; I'm getting more and more uphappy with WPML lately. I hope you will give you outmost to fix this problem asap and assist me on this.

September 22, 2016 at 2:45 pm #1095319

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

The latest version details can be found here: https://wpml.org/version/3-5-2-2/

The latest version should resolve the issue with the growing database table. You can activate the latest version and then deactivate and re-activate WPML String Translation. This should truncate the icl_string_pages table and then the table should grow normally.

If you would like to send me a copy of your site, I will be happy to test this locally. You can make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will enable the next reply to be private so only you and I have access to it.

September 22, 2016 at 9:37 pm #1095974

Shivani Verma

I'm having the same problem, I updated to 3.5.3 and updated all the WPML plugins to latest.

I'm still getting a ton of Table 'wp_visualstudio.wp_icl_string_pages' doesn't exist errors.

I found other people resolved this by adding the table however I don't know what structure the table should be. Can you please help?

September 23, 2016 at 6:07 am #1096171

joanv-3

Hi Lauren, As mentioned before, I cannot make snapshots/backups. I tried several methods/plugins among which Duplicator, but this one also gave exporting errors, probably due to time-outs while exporting the large database tables. I managed to make a backup with the hosting company and I will try to update WPML to 3.5.2. I'll revert if this is successful and if this solves the problem.

September 23, 2016 at 4:48 pm #1098003

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Lauren is currently off line today.

I would like to inform you that we have released WPML version 3.5.3 today

Please update to the latest version

Kind Regards,
Bobby

September 27, 2016 at 6:04 am #1101688

joanv-3

Hi, after the update to 3.5.2 the table size was reduced. Now the table is growing again, however at a very low rate; ref image. Is this normal behavior? I'll update to 3.5.3 today, after I've made a backup.

September 27, 2016 at 7:07 pm #1103103

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the screenshot !

Please update to WPML 3.5.3 and update me with your results

Thank you.
Bobby

September 29, 2016 at 7:24 am #1104305

joanv-3

Table is still growing after update to 3.5.3, though not as fast as before, ref image

September 29, 2016 at 8:13 pm #1105166

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

With this WPML version you should have a much better size of a table and it should of have reduced the size..

this is the public documentation
=>https://wpml.org/errata/big-icl_string_pages-table-wpml-3-5-0-causes-performance-issues/

Your rows were at 2.315.437 rows and 87.2MB and now 21k and 3 ? correct?

are you still having issues transfering due to the size?

October 4, 2016 at 12:52 pm #1107976

joanv-3

Hi, Database table is still growing in a slow pace. For now I'll assume that is normal behavoir. I'll keep a close watch on it and will report back when it gets to big again. Making site snaps is ok again.

January 8, 2019 at 9:25 pm #3068940

bedri-firatK

hello i have same problem and i use WPML 4.0.8. Do you have a resolve?

wp_icl_string_pages 701,6 mb

May 6, 2019 at 9:44 am #3746597

sanderG

Hi There,

For a couple of month I have the same problem. I run WPML Multilingual CMS 4.2.6 and WPML String Translation 2.10.4 (currently turned off because of the problem). If I turn on string translation, my database expands with about 5 mb per minute.

May 12, 2019 at 6:02 am #3792409

ugoL-3

Hi

I have the very same problem and I need to bring my database back to its normal size A.S.A.P. as I am exceeding by far my disk quota.

I paste below the message I got from my host.

Can you please help finding a solution ASAP?
Thank you
-------------------

... the database here is unbelievably huge relative to the amount of content on the site. This is almost entirely the 'wp_icl_string_pages' database table. It contains over 187,000,000 rows using up >10 GB on its own. Those rows are just content like this:

id string_id url_id
187652001 2981 7
187652002 2994 7
187652003 2951 7

And that continues for the 187 million+ rows. I think the translation plugin you're using (which is what this is related to) is going into some kind of loop and just continually writing to this table - it may be worth contacting their support to see if there is some way to stop this or if the content can be purged.