This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by thomasS-44 1 year ago.

Assigned support staff: Bobby.

Author Posts
September 21, 2018 at 3:14 pm

thomasS-44

I am trying to: let de-URLs indexed by Google

Link to a page where the issue can be seen: hidden link

I expected to see: Search console should say: Indexed

Instead, I got: "This page is not in the index"

September 24, 2018 at 6:07 pm #2761514

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

this is most likely happening due to having Browser Language Redirection enabled from within WPML->languages

when the browser language redirection is enabled the indexing of the site is affected as Google will index the URL that is most often visited and since most users have their browsers set to English by default the English URL is most often indexed.

we recommend deactivating the Browser language redirection and waiting a few days for Google to resolve the indexing .

October 2, 2018 at 9:00 am #2780762

thomasS-44

Hold on please, the problem can't be seen as resolved at this moment because I still need more positive feedback from Google Search console. I'll come back to this item at the end of next week. Hope that everything will be fine then. Thanks for your Answer btw.

October 2, 2018 at 7:28 pm #2782580

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

No problem ! Once ready please reply here and i will be notified

October 7, 2018 at 2:05 pm #2793872

thomasS-44

My issue is resolved now. Thank you!