This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to synchronise German and Polish version. Hero content and Portfolio cannot be synchronised between these two languages. I get either the German version on the Polish version of the site or the opposite.

Solution:Th cause of the issue is that the theme uses a transient to retrieve the Hero content. WPML can't translate it. But the theme checks if the transient exists, and if it does not uses the theme options, which are translated, and retrieves the content again.

So, as workaround, add this in functions.php: if (class_exists('sitepress')) { add_action( 'decree_before_content', function () {delete_transient( 'decree_hero_content' );}, 29 ); //add a line for each transient }

Relevant Documentation:

This topic contains 34 replies, has 2 voices.

Last updated by Carlos Rojas 1 month ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 13, 2019 at 8:06 pm #4390509

pawelZ-11

I am trying to synchronise German and Polish version. Hero content and Portfolio cannot be synchronised between these two languages. I get either the German version on the Polish version of the site or the opposite.

August 14, 2019 at 12:19 pm #4394771

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Could you describe the steps you are following in order to reproduce the issue?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

August 14, 2019 at 12:41 pm #4394837

pawelZ-11

I tried to increase the PHP Memory Limit earlier. I do not have WordPress installed. I actually do not use WordPress expept for Decree-pro. I know how to build a page based on decree-pro (I have a few) but I do not have any idea about the WordPress code or issues. I have just checked some Internet informations and it does not help. Everyone seems to assume that I have wordpress "installed" while I don't! I just use Decree pro. In effect I do no know where to find wp-config.php file. I thinkt that this solution might work. I would try it first as I think that I am synchronising the versions in the right way. Could you help me a little more with the wp-config.php file? Where can I find it?

August 14, 2019 at 12:47 pm #4394895

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you for your message.

I assumed you had WordPress installed because it must be installed somewhere 🙂

To edit the wp-config.php file I recommend you to contact your hosting provider and ask them to do this changes for you. They should be able to do it with no effort.

Regards,
Carlos

August 14, 2019 at 2:36 pm #4396023

pawelZ-11

It was done.

The pages run now smoother but it has not helped to solve the problem. On the printscreens you can see 1. meking menus (PL, DE), 2 Synchronizing.

Later on it is what it is i.e. on DE you can see in Hero content and in Portfolio content PL instead of DE while PL is o.k.

August 15, 2019 at 2:07 am #4398243

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

August 22, 2019 at 10:01 am #4438273

pawelZ-11

Hallo Carlos,

***

You would be welcome to intervene directly into the page!

Regards,
Paweł Żerański

August 22, 2019 at 1:25 pm #4439683

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Paweł,
Thank you for your message.

However I need you to share the credentials in your next (private) message, within the correspondent fields, this way I will have access to the credentials and therefore the site.

Note: Sharing the credentials in the fields in your next answer is totally secure.

Looking forward to your message.
Regards,
Carlos

August 23, 2019 at 7:01 pm #4449571

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

You shared the same credentials (FTP credentials) as before. I need wp-admin credentials to access the site's backend.

Please edit your previous -private- message and add the wp-admin credentials.

Regards,
Carlos

August 27, 2019 at 10:08 pm #4469955

pawelZ-11

Done.

August 28, 2019 at 10:09 am #4473041

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I tried to access the site with the wp-admin credentials but they failed. Please double check the credentials and edit your previous (private) message if necessary.

Regards,
Carlos

August 29, 2019 at 9:22 am #4479181

pawelZ-11

Pls. try with the new link I've just given. I am also asking my hosting provider what might be wrong.

August 29, 2019 at 11:36 am #4480555

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
This time I was able to log in the site correctly.

I applied some troubleshooting steps and I can't see the issue (maybe because I don't speak PL nor DE).

Please visit the test site again and if the issue persists I kindly ask you to make a screencast where you reproduce the issue, or describe step by step the issue and attach screenshots where the issue is highlighted.

I also recommend you to visit this link where you will find the steps to follow in order to translate the menus correctly: https://wpml.org/documentation/getting-started-guide/translating-menus/

Regards,
Carlos

August 30, 2019 at 12:32 pm #4487171

pawelZ-11

I had applied the rules from https://wpml.org/documentation/getting-started-guide/translating-menus/.

After your intervention nothing has changed. Pls. see the attached screenshots. The problem itself is quite simple: under PL we have two language versions mixed up.

Gerally ł,ó,ż,ź,ć,ś etc is PL while ü,ß,ä,ö etc is DE.

Pls. help!

August 30, 2019 at 1:48 pm #4487549

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

After taking a more deeper look I have found the cause of the issue.

The elements that weren't showing correctly weren't registered by WPML because the file wpml-config.xml within the theme's folder wasn't complete. I have added all the options from the theme and now you can translate them in WPML -> String Translation -> Under de ' admin_texts_theme_mods_decree-pro' domain.

I have fixed the element that your highlighted in the attached image of your previous message. As I don't speak German nor Polish I kindly ask you to double check the homepage again for more elements that might still be shown in the wrong language and if you find more, please attach screenshots where this elements are highlighted so it will be easier for me to identify them and fix them.

Regards,
Carlos