Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The default variation is not syncing for one of my products.

Solution: The variations was built using a custom attribute. To resolve it, I created a global attribute "Display Size" and added all of the sizes that you had previously entered. I then translated it by going to WooCommerce -> WooCommerce Multilingual and clicking on the Attributes tab. After creating the translations and updating the product in both languages, I now am seeing the default size in the English language.

This topic contains 7 replies, has 2 voices.

Last updated by emanuelK-5 1 year, 7 months ago.

Assigned support staff: Lauren.

Author Posts
March 26, 2018 at 1:05 pm #1556584

emanuelK-5

Hello. We are using WPML with a WooCommerce shop. We are having some products of "variable" product type and for some of them we saved a default form value.

Strangely however, for one product the default form value will not function when opened in translated language (English) – it will load the default value only with original language (German).

All variations, labels etc. are translated properly and I really wonder why this is happening with one product while other variable products with a default value are working fine in both languages.

What can we do to fix this error? I can unset or change the default value for this product as I wish (I tried several times, and checked and updated the translation too), but it will always work for the main language only. I also made a copy of that product, still the same.

March 27, 2018 at 8:07 pm #1558345

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thank you for contacting WPML support. I'll be happy to help you with this. Please make sure you have a full backup of your site before testing the steps below.

Please go to WooCommerce -> WooCommerce Multilingual and click on the Attributes tab. Select from the drop down the variation that is missing the default value. Then, click "Synchronize attributes and update product variations". Does this resolve the issue?

If not, go to WPML -> Support -> Troubleshooting. In the Clean Up section, select products from the drop down and click Synchronize post taxonomies. Now, are the default values showing up correctly?

March 29, 2018 at 5:00 pm #1560368

emanuelK-5

Hello, thanks for your suggestions. At the WooCommerce Multilingual Attributes tab however I can see only the 3 existing default attributes from installtion - Brand, GTIN and MPN - and it will show no products when selecting any, as we are not using attributes at all. So there is no way to go to variations. However I chose "Brand" and clicked the "Synchronize" Button (no noticable effect).

I also used the troubleshooting option to Synchronize post taxonomies for products and variants. Still, the default value will show only in original language.

Can we check further? If you need to login and have a look: I already created a support login for another current ticket, can you use that? The troublesome product is hidden link but it's only visible with login.

March 30, 2018 at 4:17 pm #1561075

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

April 3, 2018 at 5:24 pm #1563929

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thanks for sending credentials. I believe this issue is being caused by a conflict with one of your other plugins or your theme. I created a snapshot of your site to further test this locally, and here's what I found.

I deactivated all non WPML plugins (except for WooCommerce, of course) and changed the theme to Twenty Seventeen. With these settings, I then created a new variable product and set a default option. I translated the product to the secondary language. The default option showed on both languages as the default on the frontend of the site.

Is it possible for you to test this on your site or on a staging site? Be sure to make a full backup first.

April 4, 2018 at 2:36 pm #1564959

emanuelK-5

Hello Lauren, I am not so sure about this being a general plugin or theme conflict. Because we have several other products with a default value set and it is all fine with them.
For example: hidden link - here we have set default product variation (Language: Dutch) and it works fine in German and English. As well as with other products which I have tried setting a default value. hidden link seems so be the only one where it does not work for the translated language.

April 4, 2018 at 6:08 pm #1565226

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I think there was something wrong with the custom attribute. To test this, I created a global attribute "Display Size" and added all of the sizes that you had previously entered. I then translated it by going to WooCommerce -> WooCommerce Multilingual and clicking on the Attributes tab. After creating the translations and updating the product in both languages, I now am seeing the default size in the English language. Can you please test this in a cleared browser and confirm that you are seeing the same thing?

April 5, 2018 at 1:47 pm #1566071

emanuelK-5

Hello Lauren, thanks a lot, yes I can confirm! Now it is working perfectly.

Though I had to correct the German translations for the 6 taxonomies of the new attribute "Display Size" and then update the default value at the product data editor. Changed it several times to check, all fine. 🙂

Best regards, Gregor