We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 6 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 13, 2019 at 4:14 pm

andreaB-8

I am trying to: to install and set default language

I installed WPML and when installed all my content has been set as EN default language.... but my site is Italian.... that means that if I set Italian as default language I see all missed and broken. Old layout... not menu etc..
What I need is: current site (text, pages, menus....) needs to be set as ITALIAN ... and I'll on ENGLISH creating new language

Link to a page where the issue can be seen: hidden link

I expected to see: current pages in Italian language default

Instead, I got: when I set Italian as default language all pages become missed

May 13, 2019 at 7:46 pm #3801413

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Before a further look, please, let me understand the whole context of your request. You had already a website setup with italian content, right? Then you installed WPML with english as the default language, but now you need to change your default language as italian? If so, I recommend you to take a closer look into this topic: https://wpml.org/forums/topic/setchange-language-for-existing-content/ it deals with the same issue. Don't forget to keep a backup copy of your website when following the mentioned steps. Please, let me know if it helps, have a nice day.

May 13, 2019 at 7:52 pm #3801427

andreaB-8

I posted all info for access to my site!
Can you kindly do from your side?
What I need... what now is set as ENG I need that is ITA... cause of my site is in Italian.... so please change default language (with current content and menu ant pages) making all in Italian

May 13, 2019 at 9:54 pm #3801805

andreaB-8

Please help me!!

May 14, 2019 at 12:08 am #3802297

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Before any change in the settings of your website we need to make sure you have a backup copy. It is required so we can avoid any potential issue and data loss. Please, let me know, have a nice day.

May 14, 2019 at 12:31 am #3802337

andreaB-8

Sure backup is OK!
Please make what I asked.
What now is English I need Italian (all pages and style)

May 14, 2019 at 7:09 am #3804217

andreaB-8

Please I'm still here and I need to fix this issue 🙁

May 14, 2019 at 6:36 pm #3809985

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and your patience while waiting for a solution. I've reseted your WPML settings and setup Italian as your default language, now all your website content is in Italian and you can proceeding with the english translations (see https://wpml.org/documentation/getting-started-guide/). Please, let me know if you need any additional assistance and clarifications. Have a nice day.