This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by khalidA-27 5 months, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 2, 2019 at 2:15 pm #3725547

khalidA-27

Hello

My default wordpress language is English. I wanna keep it like that.

How can I make the default language for visitors Arabic. And keep wordpress language as English

Thanks

May 2, 2019 at 3:21 pm #3725971

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I am not sure that I fully understand what you mean so can you please elaborate a bit more?

When you say "How can I make the default language for visitors Arabic." do you refer to the language in the backend, inside the WordPress panel?

If you are referring to the front-end language instead, you would need to either set the Arabic language as default language inside WPML (but please make a full backup of the site first) or turn on browser automatic redirection (https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/).

Please let me know what you are referring to.

I will be waiting for your answer.

Kind regards,
Mihai Apetrei

May 2, 2019 at 5:57 pm #3727953

khalidA-27

Thanks for reply.

My admin panel interface is English. I wanna keep it that way.
But in the same time I want Arabic to be the language for all visitors to front-end . Without redirecting URL 🙂 🙂

Could it be done?

May 3, 2019 at 2:16 pm #3735119

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

In order to accomplish that, you would need to go to WPML > Languages and set "Arabic" as the default language.

However, please make a full website backup first in case something unexpected happens.

Also, from what I can see in the debug information that you added, if you go to your WordPress Dashboard > Settings > General, you should see the same link for both "SiteURL" and "HomeURL" but for the moment it seems that for the last one, you are using a different link (the one with the /en attribute - both should be the same so this one should be set back to the same one from "SiteURL").

Please let me know how that goes.

Kind regards,
Mihai

May 4, 2019 at 7:11 am #3739339

khalidA-27

Hi Mihai

Thanks for reply

1- "In order to accomplish that, you would need to go to WPML > Languages and set "Arabic" as the default language."

This makes site default language Arabic. But in the sane time it makes admin panel also Arabic. Which I don't want. I want front end default is Arabic for visitors. And Admin panel English.

2- "Also, from what I can see in the debug information that you added, if you go to your WordPress Dashboard > Settings > General, you should see the same link for both "SiteURL" and "HomeURL" but for the moment it seems that for the last one, you are using a different link (the one with the /en attribute - both should be the same so this one should be set back to the same one from "SiteURL")."
I don't really understand what you mean here 🙂 . Do you mean to enter site URL to hidden link ???
I did that but when I visit site it became hidden link and my site gave me
500 error . Then I return it back to hidden link But the error remain

Please elaborate more about what you mean. And how can I undo this error?
Thanks 🙂

May 6, 2019 at 10:19 am #3746971

khalidA-27

More than two days and no reply

May 6, 2019 at 4:49 pm #3751259

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hello and sorry for the late reply but I am not working on the weekends so it was only now that I was able to answer you.

1. You can change the backend language of the site by following the next steps:

- Go to your WordPress dashboard > Users > Your Profile
- Scroll to the "Language" section
- Choose "English" from the dropdown
- Scroll to the bottom of the page and click the blue "Update Profile" button

2. What I mean here is that there should not be 2 different links. Both of them should be "hidden link". So I recommended a full website backup first and then changing the /en link to the default one and that way, WPML is able to add the /en by itself.

I hope this information helps and clarifies things a bit more. 🙂

Please let me know if you still have questions. I am at the end of my shift at the moment but if you will be able to reply today or tomorrow (in the first part of the day), I can answer you on the same day.

I also want to let you know that in case you prefer to use our live chat feature, you should be able to do that by marking this ticket as resolved and then go here (https://wpml.org/forums/forum/english-support/), select to create a new ticket and then select the live chat option as you can see in the screenshot I attached.

I will be waiting for your answer.

Kind regards,
Mihai

May 7, 2019 at 6:35 am #3754415

khalidA-27

My issue is resolved now. Thank you!