This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to install Woocommerce to an English & French web site but something about my configuration must be wrong as the Woocommerce thinks my default language is French.

Solution: Creating my own pages and setting them the woocommerce advanced settings solved the issue

Relevant Documentation:

This topic contains 9 replies, has 2 voices.

Last updated by Carlos Rojas 1 month, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 3, 2019 at 10:39 pm #4507427

melaniep-8

I am trying to:

I am trying to install Woocommerce to an English & French web site but something about my configuration must be wrong as the Woocommerce thinks my default language is French. I know 100% that I was editing the English site when I installed the plugin. I even DELETED (fully) woocommerce and all its tables and re-installed. Same issue again.

IMPORTANT NOTE: This domain is not live. Currently hidden link redirects to a different name. To see this site under development you MUST EDIT your PC's hosts file here: C:\Windows\System32\drivers\etc and add

#4goodhosting
162.244.239.124 amgdrivingacademy.ca
162.244.239.124 hidden link

Link to a page where the issue can be seen:
hidden link
will redirect you to
hidden link

I expected to see:
Not the redirect for one.

Instead, I got:

September 3, 2019 at 10:56 pm #4507445

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

September 3, 2019 at 11:29 pm #4507485

melaniep-8

Also - as this install of WooCommerce is fresh I have no problem deleting it and starting again! And to that end I just also added

define( 'WC_REMOVE_ALL_DATA', true);

to my wp-config.php files so that if you want to do that you can - adding this apparently deletes all database tables and everything associated with WooCommerce install when the Plugin is deleted in the backend of WP.

September 4, 2019 at 9:23 am #4509665

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

However every time I try to visit the wp-admin page I get redirected to hidden link

Could you tell me if there is other URL for login? Or could you deactivate the redirection?

Regards,
Carlos

September 4, 2019 at 4:15 pm #4512787

melaniep-8

Carlos - how do I get a real-time chat going, like I did the other day? Please answer this question.

Also, you missed the part of my initial question that read:

IMPORTANT NOTE: This domain is not live. Currently hidden link redirects to a different name. To see this site under development you MUST EDIT your PC's hosts file here: C:\Windows\System32\drivers\etc and add

#4goodhosting
162.244.239.124 amgdrivingacademy.ca
162.244.239.124 <em><u>hidden link</u></em>

There is no way of my turning off the redirect temporarily. My client wants the old site live until the new site is completed.

September 5, 2019 at 10:49 am #4518535

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
You can open a new chat ticket and reference this ticket.

Anyways, I was able to log in the site by opening an incognito tab, it seems the browser cache hasn't refreshed yet.

In order to solve this issue I would like to ask you to follow this steps:
- Go to hidden link -> Duplicate the page in English -> Save the changes -> Make sure that the URL is correct ->Delete the French version of the page.

Could you tell me the results of the steps above?

Also, please go to Woocommerce -> Settings -> Products and set the Shop page.

Regards,
Carlos

September 5, 2019 at 10:04 pm #4522059

melaniep-8

No. That only partially worked. And I feel it does not address the underlying issue which is, somehow the default language is set to French even though the settings say the default language is English. Earlier, with another ticket I was trying to edit some Custom Theme footer content. WPML saw that content as being French by default. It's the same underlying issue - I am sure of it. If we fix that. I can delete Woocommerce and reinstall it and I bet this issue will go away.

But to answer your question..
I did as you requested. I now have this page hidden link
BUT ... if I go to Appearance / Menus / and if I add a Woocommerce Endpoint for Account Details it then uses this URL hidden link and that page does not exist. You can see this link in my Top Bar. And so, this does not change what Woocommerce thinks is the Account page, and links it creates will be going there (I know I can use the page we just created but this is a bandaid to the real problem which is not getting fixed)

September 6, 2019 at 8:54 am #4524157

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your message.

1.- It seems that the setup of Woocommerce wasn't the 'traditional setup' or some issue happened during this. If you go to Woocommerce -> Settings -> Advanced tab -> You will see that none of the page are setup there which is very strange and is not related to WPML.

Anyways, I would like to ask you to setup this pages in Woocommerce, then follow this steps:
- Go to WPML -> Support -> Troubleshooting link -> Apply the steps highlighted in the attached image.

Could you tell me if the issue persists?

2.- Also, could you tell me if you are planning to use Woocommerce Multilingual plugin?

Regards,
Carlos

September 6, 2019 at 5:57 pm #4527011

melaniep-8

Carlos - I have done all that you said. The install was fresh and nothing was not traditional - and I was happy to uninstall it and start again. Usually those pages are created and set with the install - and they were - but they were created on the french site - which is why I still think there is an underlying issue with WPML. But creating my own pages and setting them the woocommerce advanced settings is good enough for me know.

September 9, 2019 at 9:54 am #4535667

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos