This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by michalN-8 2 months ago.

Assigned support staff: Bruno.

Author Posts
August 16, 2019 at 12:37 pm #4406303

michalN-8

I am trying to:

Translate login popup

Link to a page where the issue can be seen: hidden link
Click on "EINLOGGEN" link on the top right side to open login popup.

I expected to see:
Strings translated to German, as it active language on .wien domain

Instead, I got:
Polish strings displayed, as it is default language. But it should be displayed only on hidden link domain.

From login popup template:

<p class="woocommerce-form-row woocommerce-form-row--wide form-row form-row-wide">
						<label for="username"><?php esc_html_e( 'Username or email address', 'woocommerce' ); ?>&nbsp;<span class="required">*</span></label>
						<input type="text" class="woocommerce-Input woocommerce-Input--text input-text" name="username" id="username" autocomplete="username" value="<?php echo ( ! empty( $_POST['username'] ) ) ? esc_attr( wp_unslash( $_POST['username'] ) ) : ''; ?>" /><?php // @codingStandardsIgnoreLine ?>
					</p>
					<p class="woocommerce-form-row woocommerce-form-row--wide form-row form-row-wide">
						<label for="password"><?php esc_html_e( 'Password', 'woocommerce' ); ?>&nbsp;<span class="required">*</span></label>
						<input class="woocommerce-Input woocommerce-Input--text input-text" type="password" name="password" id="password" autocomplete="current-password" />
					</p>

I've investigated it and when I change Polish translation- the updated Polish value is displayed. So it takes Polish (default) language translation but it is not correct because on .wien domain, the German language should be displayed.

August 16, 2019 at 8:34 pm #4408127

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, follow the steps below:

- Click on the WPML > Languages > Language filtering for AJAX operations
- Check the "Store a language cookie to support language filtering for AJAX" option
- Click on the Save button

After following these steps, reload the page and try again following the steps you posted above and see if your login is showing correctly.

Thank you.

August 19, 2019 at 6:24 am #4413675

michalN-8

My issue is resolved now. Thank you!