This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Radu 6 months ago.

Assigned support staff: Radu.

Author Posts
April 17, 2019 at 9:58 am #3629329

eric lo

the site is heliosgroup.com.hk

with existing Traditional Chinese content, when I installed wpml and set Chi as default lang, it changed all URLs by adding 'en' to them, we cannot live with that of course... then I change it back to Eng as default and it is showing all old content in Chi, what is the efficient way to do it so that we don't have to move content page by page to new URLs for chinese pages??

April 17, 2019 at 11:53 am #3630343

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Eric,

Thank you for reaching out the WPML support!

Can you tell me where I can find the language switcher button, please? I checked your website, trying to compare the English and Chinese page links but I could see any option to go to the English version. Can you tell me how can I do this change, please?

Thanks,
Radu

April 17, 2019 at 1:32 pm #3631257

eric lo

We haven't create eng pages yet, but the issue already scare the client. As I tried to change default language to traditional Chinese but then a urls will change with wording like zhhant, is there a way to set chi as default but url won't change?

Otherwise need to move content page by page (as now all pages default as Eng but content created is in Chinese)

April 18, 2019 at 1:49 am #3635283

eric lo

i added to the footer, but hided it from search engine otherwise will have 404

under setting of wpml, I see: It looks like languages per directories will not function

give me private box if you need access to our cms, thanks

April 18, 2019 at 7:33 am #3636835

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Eric,

I set the next message to be private so you can send me the credentials for your website. This way I'll check things a bit closer and see why is this not working as expected.

Thanks,
Radu

April 18, 2019 at 10:52 am #3638507

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Eric,

As I can see, all your pages are now assigned to the same language (English). Now, yo need to edit each Chinese page, set its language from the right sidebar and set the original page for it. This way, the pages will be translated fine again. Before doing this, please deactivate all the caching plugins you have. As I can see, you're using SiteGround plugin and this can be a bit too "aggressive" sometimes. While this is a very useful tool when the website is done, it might cause some issues while still working on the website (doing changes, modifying different options). Can you do this and tell me how things work, please?

Thanks,
Radu

April 18, 2019 at 11:29 am #3638739

eric lo

Do you mean I need to manually copy and paste every page to new URLs of Chinese pages?? No other method?

Also, I am confused why if I set default language as Traditional Chinese, the existing URLs changed with wordings 'en' added? Shouldn't the default language be without any country code?

April 19, 2019 at 7:50 am #3643905

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Eric,

I wasn't suggesting creating all the pages from scratch. You can edit any Chinese page (like this hidden link for example) and change its language from the right sidebar (please see the attached screenshot). Once you did this, a new field will appear right under this, letting you set the English version of this page (I attached a screenshot for this too). If you want, you can send me the links of a page from your website for both languages and I'll do this change for you, as an example.

Thanks,
Radu

The topic ‘[Closed] Default language issue’ is closed to new replies.